1

Since Ubuntu 18.04 (my previous version was 16.04) I have noticed quirks in my earlier working nicely custom XKB configuration.

I set my configuration by running

xkbcomp -I$HOME/.config/xkb/ $HOME/.config/xkb/map.xkb :0

map.xkb file contains

xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete+ledscroll(group_lock)"    };
    xkb_symbols   { include "pc+my(intl)+inet(evdev)+group(shifts_toggle)"  };
    xkb_geometry  { include "pc(pc104)" };
};

But the option group(shifts_toggle) is completely ignored (system default super+Space works though).

Also running xkbcomp $DISPLAY output.xkb gives (providing only a small excerpt):

xkb_symbols "pc+my(intl)+inet(evdev)+group(shifts_toggle)" {

    name[group1]="English (US)";
    name[group2]="Russian (my custom layout)";
    name[group3]="English (US)";

    key  <ESC> {         [          Escape ] };

It shows three groups though my symbols definition has only two (English+Russian). It looks like system makes additional modifications. Can I switch those off?

Any help really appreciated since XKB is rather important yet always poorly documented topic.

1
  • Here is the output of setxkbmap -v 10 – Pommy Nov 11 '19 at 2:29
0

I presume you’re using GNOME 3; if so, it is not currently possible, see this upstream bug.

In case it is Unity, this may help:

gsettings set org.gnome.settings-daemon.plugins.keyboard active false
3
  • I am using GNOME. I am not 100% sure that the bug you mention is the issue I am reporting here, though it might be. Also want to note that custom layout do work, I just notice weird system interference with layout switching in particular. – Pommy Apr 9 '20 at 14:59
  • This has been my observation as well. I have a custom switcher on Super (Super = first layout, Shift-Super = previous layout), and it doesn’t work in GNOME at all. (I reported the bug.) – andrewsh Apr 12 '20 at 14:55
  • In the meantime I am using xbindkeys to set required layout anew on every layout switching combination key stroke. Gnome on Arch Linux doesn't seem to interfere with it )) – Pommy Apr 13 '20 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.