5

currently I have allocated 2 GB swap size (RAM size in my machine is 8 GB) tried setting the swappiness value to 10 and right now the value is 1 but still Ubuntu is using swap when the used ram hits close to 60% thus making the system sluggish.

Is it a known issue/bug with ubuntu 19.10? I've tried turning off swap with swapoff -a but this is also changes after reboot. Any suggestion will be much appreciated.

  • To permanently remove swap, you can stop your swap partition from being mounted in /etc/fstab by commenting it out, but I don't really recommend it since even if you go 1 byte over your memory limit, your system will crash. – darksky Nov 9 '19 at 8:40
  • yes , disabling swap is not a choice , it is that i'm using this time to time when system is getting sluggish after swap memory usage. – himel Nov 10 '19 at 5:27
  • With vm.swappiness = 1 and 8GB of memory you shouldn't experience that. Have you edited the file /etc/sysctl.conf? – darksky Nov 11 '19 at 4:10
  • yes , i thought that too but weirdly I'm experincing the same , now I'm also looking into the NVIDIA driver version as I'm suspecting this could be the culprit too. – himel Nov 11 '19 at 8:43
  • Actually, I'm experiencing something similar. I set the swappiness to 1, but I notice when there is a sudden allocation of large amount of memory due to a VM loading, the swap starts activating again. I haven't had an issue with swap until 19.10 -- which seems to completely kill the system with lag when swapping. In my case, it is a Haswell cpu on a laptop with integrated graphics. – darksky Nov 11 '19 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.