5

I'm not sure if other browsers or programs have this issue, but I've noticed it while using Firefox, on YouTube or Pandora. When a new video/track begins, the output audio of the browser (not the main volume) becomes lower. My guess is something trying to optimize sound quality, but when I'm making a bunch of noise, I need volume over quality. Pictured is my audio window showing the new Firefox audio being lower than it was before.

screenshot of Playback tab in Volume Control

4
  • you can find lots of similar bug reports like this support.mozilla.org/en-US/questions/1201925 it's been for a couple of years now. – JoKeR Nov 9 '19 at 0:03
  • also similar askubuntu.com/questions/967061/… – JoKeR Nov 9 '19 at 0:11
  • I tried the delete /mozilla folder suggestion from the other topic. I had to reset all my passwords and bookmarks, but the problem persists. In fact it seems worse. What used to be a drop to 80% is now dropping to around 60%. The support link seems to be a solution for windows. I could not find an ubuntu solution there. @JoKer – Liberated Amon Nov 10 '19 at 1:34
  • I meant to say that it is a bug not only for Ubuntu and it's been happening for years so you'd better file it as a bug report. – JoKeR Nov 10 '19 at 21:38
1

In case someone comes across this question (as did I), there is an answer here: Inconsistent Sound Volume Ubuntu 20.04

Basically, you need to change flat-volumes = no to flat-volumes = yes. The values "true", "1" and "on" are equivalent to "yes", according to the manpage (https://manpages.ubuntu.com/manpages/focal/man5/pulse-daemon.conf.5.html):

For the settings that take a boolean argument the values true, yes, on and 1 are equivalent, resp. false, no, off, 0.

Don't forged to uncomment the respective line by removing the ";" or "#":

The configuration file is a simple collection of variable declarations. If the configuration file parser encounters either ; or # it ignores the rest of the line until its end.

The configuration file is: /etc/pulse/daemon.conf

Other possible locations are: ~/.config/pulse/daemon.conf, ~/.config/pulse/daemon.conf.d/*.conf and /etc/pulse/daemon.conf.d/*.conf:

The PulseAudio sound server reads configuration directives from a configuration file on startup. If the per-user file ~/.config/pulse/daemon.conf exists, it is used, otherwise the system configuration file /etc/pulse/daemon.conf is used. In addition to those main files, configuration directives can also be put in files under directories ~/.config/pulse/daemon.conf.d/ and /etc/pulse/daemon.conf.d/.

According to the aforementioned post, rebooting is necessary for the change to take effect.

About the configuration option:

flat-volumes= Enable 'flat' volumes, i.e. where possible let the sink volume equal the maximum of the volumes of the inputs connected to it. Takes a boolean argument, defaults to no.

EDIT: I tested the solution myself and it worked (Ubuntu 20.04).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.