0

partition shows full in df -h

I have been using Ubuntu 18.04 LTS for a couple of months. While using it today, suddenly I encountered a problem in saving files. It throws Disk space full error.

Then, I looked into my files and noticed the disk looks full. But I only had around 25 GB of data saved in my 1 TB HDD. Then, I tried rebooting the PC and it froze after the startup page where we see the services getting started. It is still the same even after multiple reboots. Please help out getting this fixed.

  • 1
    Have you partitioned your disk into smaller partitions? If the OS partition goes full it does not matter how large your storage drive total is. – Smurfz87 Nov 8 at 13:04
  • No, Smurfz87... It was partitioned fully as recommended. – Jerome Jerry Nov 8 at 13:32
  • 1
    And your error is for "disk space full" not "boot partition full"? If possible post output of df -h – Smurfz87 Nov 8 at 13:35
  • Sorry for the delay.. I was help up with some works.. I have attached a copy of the result in the question above... please look into it – Jerome Jerry Nov 8 at 14:45
  • and if you run sudo du -sh /dev/sda5 ? – Smurfz87 Nov 8 at 15:03
0

I would strongly suggest using a Live Ubuntu CD/Flash/Boot device to load a working image on to your computer, and then mounting that partition manually to see what could be occupying that partition. Personally I think the partition table has been corrupted, or there is damage to various sectors that make up the hard drive and the operating system routines are unable to figure things out. Perhaps an FSCK might help using alternate superblocks as a guide. What is /dev/sda5 actually comprised of (Physical, Logical, Hardware)? Is it really important to the boot process of your host?

Can you consider booting of the live image, mounting /cow (on target system) as /mnt (or something like that on the live system) and manually editing /etc/fstab to comment out the mount command for /dev/sda5 - that way your basic system (target system) will be at least be able to boot up, albeit missing /dev/sda5.

The process is difficult to grasp, but frequently done, and you will learn a lot in the process ... but will need a few tools as mentioned in : https://help.ubuntu.com/community/LiveCdRecovery, also https://help.ubuntu.com/community/FilesystemTroubleshooting, (hopefully you will not have serious problems, and can do: https://www.maketecheasier.com/check-repair-filesystem-fsck-linux/) and most relevant IMHO: Unmount drive from emergency mode

  • I tried this earlier, but it didn't work... That corrupted partition doesn't show up in the fstab entry, when booting on Live OS... Is there any way to get this done??? – Jerome Jerry Nov 8 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.