0

This is the command I used:

sudo mount -t cifs //10.8.0.9/KeyA /media/KeyA/ -o username=,password=

When executing this command, the command suspiciously takes only a little amount of time (used to be 5 seconds+, now it is like 1.5 seconds), and the mount point is completely empty.

So I checked /proc/mounts to see if CIFS even did anything at all, and of course it didn't even mount the target. I have tried specifying vers=3.0 (target server minimum version), and have even tried lowering the version to 1.0 on the target server with no avail. This command worked completely fine an hour ago

Why does CIFS fail here, and why is it broken so damn always?

  • Try looking in your log files for errors or anything standing out. The files that CIFS reports to is /var/log/kern.log and /var/log/syslog. If you cat either file right after trying to connect the last few lines should give you some clues. – Terrance Nov 8 '19 at 4:04
  • @Terrance Thank you for the reply, however nothing juicy in here: kern.log reports "kernel: [ 5763.495186] CIFS: Attempting to mount //10.8.0.9/KEYA" and syslog reports "kernel: [ 5759.581216] CIFS: Attempting to mount //10.8.0.9/KEYA" Nothing too alarming – Tyler DeBoy Nov 8 '19 at 4:09
  • Honestly, I went to NFS for my mounts because Samba (CIFS) works better with Windows. I had a bug that I had to file against CIFS for file usage discrepancy. askubuntu.com/questions/1058815/… – Terrance Nov 8 '19 at 4:10
  • @Terrance OH YES PLEASE! How do I use NFS instead of CIFS? CIFS never works for me, and I have redesigned my encryption system 5 times now because of CIFS errors lol – Tyler DeBoy Nov 8 '19 at 4:12
  • I believe this is exactly what I followed for both my server and client. help.ubuntu.com/community/SettingUpNFSHowTo – Terrance Nov 8 '19 at 4:14
0

SO... this was very frustrating. I had two errors on both nodes that caused this side effect to happen

On the server side (where the target share is located), samba/cifs/nfs was COMPLETELY broken. I was not even able to mount the share on a different device. I have no idea what the hell happened to it. Luckily I had made an image the week before and restored the disk.

On the client side (where I wanted to mount the network share), /media/KeyA (the mountpoint directory) is corrupted. Anything I tried to mount there would always fail to be listed... I tested this theory by setting the CIFS mountpoint to /temp instead of /media/KeyA and it worked just fine.

Out of all the issues I have had, this one definitely was the hardest to detect. Lets just hope this never happens to anyone else. Thank you Terrance for your help!

Update: Client folder is still corrupt/not listing files. fsck did NOT work to correct this folder. Working on diagnosing this as well, but as for now, this question is closed

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.