0

I previously had Ubuntu 18.04 along with Windows 10, after having many problems I decided to install Ubuntu 19.10, but one of the main problems (boot time) was still happening, I have tried almost everything with no solutions. It's really weird since my laptop is new and shouldn't have any troubles.

systemd-analyze time
Startup finished in 3.449s (firmware) + 48.782s (loader) + 5.522s (kernel) + 52.274s (userspace) = 1min 50.028s 
graphical.target reached after 52.206s in userspace


systemd-analyze blame
     29.319s plymouth-quit-wait.service
      8.752s NetworkManager-wait-online.service
      8.734s snapd.service
      8.325s dev-sda5.device
      8.277s systemd-journal-flush.service
      6.499s networkd-dispatcher.service
      6.000s ModemManager.service
      5.693s udisks2.service
      4.703s accounts-daemon.service
      4.134s NetworkManager.service
      3.867s e2scrub_reap.service
      3.645s systemd-fsck@dev-disk-by\x2duuid-86D3\x2dF64F.service
      3.387s secureboot-db.service
      3.344s grub-common.service
      3.257s dev-loop2.device
      ...

EDIT I:

Things I have tried so far: fresh installs many times, edited grub file with "quiet splash noresume", disabled some processes that were taking a long time, and most of the common solutions that somebody could find on internet.

Results of: cat /proc/swaps && free -m

Filename                Type        Size    Used    Priority
/swapfile               file        947128  0       -2

              total        used        free      shared  buff/cache   available
Mem:          10969        1603        8030         124        1336        8958
Swap:           924           0         924

Result of systemd-analyze critical-chain

graphical.target @52.206s
└─multi-user.target @52.206s
  └─kerneloops.service @31.766s +1.015s
    └─network-online.target @31.601s
      └─NetworkManager-wait-online.service @22.848s +8.752s
        └─NetworkManager.service @18.711s +4.134s
          └─dbus.service @18.704s
            └─basic.target @18.474s
              └─sockets.target @18.474s
                └─snapd.socket @18.310s +163ms
                  └─sysinit.target @18.286s
                    └─apparmor.service @15.427s +2.858s
                      └─local-fs.target @15.423s
                        └─boot-efi.mount @14.946s +477ms
                          └─systemd-fsck@dev-disk-by\x2duuid-86D3\x2dF64F.service @10.828s +3.645s
                            └─dev-disk-by\x2duuid-86D3\x2dF64F.device @10.826s

EDIT II:

Outputs after sudo systemctl disable NetworkManager-wait-online.service

systemd-analyze time
Startup finished in 4.261s (firmware) + 12.044s (loader) + 4.338s (kernel) + 40.317s (userspace) = 1min 962ms 
graphical.target reached after 40.276s in userspace


systemd-analyze blame
     18.691s plymouth-quit-wait.service
     10.686s dev-sda5.device
      9.799s snapd.service
      9.379s configure-printer@usb-001-002.service
      6.580s systemd-journal-flush.service
      5.879s udisks2.service
      5.620s networkd-dispatcher.service
      4.928s ModemManager.service
      3.954s NetworkManager.service
      3.906s accounts-daemon.service
      3.855s e2scrub_reap.service
      2.898s apport.service
      ...

I know nothing about Ubuntu but I need it running properly for many courses. I really hope for someone to help me, thanks.

4
  • 2
    So far, looks like you didn't actually try anything. Why do you claim so much more effort? Is there stuff you tried that you have not mentioned? If so, what?
    – user535733
    Nov 7, 2019 at 22:50
  • @rigovil Please run cat /proc/swaps && free -m. Copy the results, come back here, click on edit, and paste the results into your question. Please don't use Add Comment; instead, use edit. Also please see askubuntu.com/questions/1030867/…
    – K7AAY
    Nov 7, 2019 at 22:50
  • 1
    Also systemd-analyze critical-chain. 'blame' may not reflect actual delay.
    – user535733
    Nov 7, 2019 at 22:55
  • Don’t know if it’ll help you... Slow boot issue due to plymouth-quit-wait.service + ubuntu 18.04
    – koalatree
    Nov 8, 2019 at 1:16

3 Answers 3

0

As described in this answer:

A considerable amount of your boot time can be saved with the command:

sudo systemctl disable NetworkManager-wait-online.service
3
  • Thanks for the answer. I already tried this and the boot time was still similar
    – rigovil
    Nov 8, 2019 at 2:12
  • Can you update your question with the output after the service is disabled? It will let us know what to focus on. Nov 8, 2019 at 2:32
  • Done. Boot time improved but still taking more than 1 minute
    – rigovil
    Nov 8, 2019 at 3:47
0

I have had trouble with slow boot on 18.04,19.10 and 20.04. I have found a very simple solution.

My desktop PC is connected to my router by an Ethernet cable. I have a Netgear WifFi dongle but this did not work until a recent update to the linux kernel. It now works. If the Netgear card is plugged in and the system boots you have to wait forever for the Grub menu. If the Netgear card is unplugged it boots quickly. This suggests to me that you have to choose either a wired connection or a wifi connection. Having both enabled causes confusion and delay.

-1

systemd-journal-flush.service : Try to clean the journal logs with

sudo journalctl --rotate
sudo journalctl --vacuum-time=1s

more info here Root drive is running out of disk space. How can I free up space?

Not the answer you're looking for? Browse other questions tagged or ask your own question.