3

Running Ubuntu 18.04.3, though with KDE, I'm having a lot of trouble logging into the JetBrains Toolbox (so that I can add my license and install non-free products).

When I go into the settings and click Log In, Chrome (my default browser) tries to open the link (https://account.jetbrains.com/oauth2/signin?login_challenge={hash}), which immediately redirects me to a page saying:

Oops! Something went wrong. Looks like you copied and pasted the link, it doesn’t work properly.
Please try again with your previous step on website/application or start over.

I found a recent JetBrains issue that seems identical to my experience, but the only suggestions there were to reset my default browser to Edge or Safari for the login, depending on what OS I was on. I only had Firefox and Chrome available, and both were mentioned as browsers people had had this issue with, but I tried opening the initial URL in both anyway to the same effect.

2

My KDE settings for default browser/how to open http(s) URLs looked like this:

KDE Default Application Web Browser settings, showing three options for how to open http and https URLs: in an application based on the contents of the URL(selected), in the following application (followed by a greyed out dropdown with Google Chrome visible), with the following command (followed by a greyed out textbox currently reading 'google-chrome')

Despite the fact the linked issue suggested a fix might be to do with allowing the toolbox to open jetbrains:// URLs, switching to having links directly opened in Chrome (with the second option) allowed Chrome to successfully open the Log in link and ask for permissions, allowing me to log in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.