0

Almost every time I unlock my laptop, I get the message

An application wants to create a new keyring called 'Default'. Choose password you want to use for it.

I input a password to create said "keyring" and the popup goes away, only to appear again the next time I unlock my laptop.

What's annoying is that I don't even know which "application" is trying to create the keyring.

Is there a way to troubleshoot this? That is, figure out the offending application and why the keyring creation is failing?

  • 1
    Request: can you add "Gnome" tag to the question above, for clarity? – sarlacii Nov 7 '19 at 13:38
1

While the prompt for the new keyring and password is still sitting in the terminal, check what processes are connecting to the terminals on the system:

user@pc:~$ ps axo stat,tty,pid,pcpu,comm
STAT TT         PID %CPU COMMAND
Ss   ?            1  0.0 init
S    ?            2  0.0 kthreadd
S    ?            3  0.0 ksoftirqd/0
Ss+  tty1      1297  0.0 getty
Ss   ?         1638  0.0 screen
Ss+  pts/2     1639  0.0 bash
Ss   pts/3     1640  0.0 bash
S    ?         3559  0.0 check-new-relea
Ss   pts/1     4952  0.0 bash

Where "man ps" will explain the various possible outputs (the example above uses BSD format)... and the huge selection of possible filters.

stat STAT multi-character process state. See section PROCESS STATE CODES for the different values meaning. tty TT controlling tty (terminal). (alias tname, tt). pid PID a number representing the process ID (alias tgid). pcpu %CPU see %cpu. (alias %cpu). comm COMMAND command name (only the executable name).

Look for processes that are running in a terminal like tty or pts, and look for things like gnupg, agent, and others linked to the desktop that you have running (like kde wallet manager):

user@pc:~> ps axo stat,tty,pid,pcpu,comm | grep agent
Ss   ?         2991  0.0 ssh-agent
Ss   ?         2992  0.0 gpg-agent

The prompt may well be from a wallet manager that is trying to store the password for your WiFi connection, for example, but is not able to locate an existing default wallet.

If you don't know what the terminal ID is, then kill the suspect process, and it should disappear, confirming that you got the culprit. Obviously, killing processes could make your system unstable, so reboot after you ID the process, if you guessed incorrectly. A brute-force approach.

Note that each time you login, subsequently, you will be prompted for the wallet password, so that the system can then access the stored passwords.

In the Gnome desktop system, taken from GNOME/Keyring, you need to have a default wallet or else passwords are not remembered:

If you get a password prompt every time you login, and you find that passwords are not saved, you might need to create/set a default keyring.

Ensure that the seahorse package is installed, open it ("Passwords and Keys" in system settings) and select View > By Keyring. If there is no keyring in the left column (it will be marked with a lock icon), go to File > New > Password Keyring and give it a name. You will be asked to enter a password. If you do not give the keyring a password it will be unlocked automatically, even when using autologin, but passwords will not be stored securely. Finally, right-click on the keyring you just created and select "Set as default".

  • Thanks Sarlacii. Apologies for not being clear, but the message is in a popup overlaying my gnome desktop not in a terminal. – Tohiko Nov 7 '19 at 13:09
  • Ok, then "ps" command is still your friend, just don't only look at terminal commands. But for Gnome it will be the gnome wallet subsystem (wiki.archlinux.org/index.php/GNOME/Keyring#Console_login has details) that is prompting you. See additional info in my answer. – sarlacii Nov 7 '19 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.