1

I am using Lubuntu on my laptop. I try to upgrade using sudo apt upgrade and then the following error is showing up:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  erlang erlang-appmon erlang-asn1 erlang-base erlang-common-test erlang-crypto
  erlang-debugger erlang-dev erlang-dialyzer erlang-diameter erlang-edoc erlang-eldap
  erlang-erl-docgen erlang-et erlang-eunit erlang-examples erlang-ftp erlang-gs
  erlang-ic erlang-ic-java erlang-inets erlang-inviso erlang-jinterface erlang-megaco
  erlang-mnesia erlang-mode erlang-observer erlang-odbc erlang-os-mon
  erlang-parsetools erlang-percept erlang-pman erlang-public-key erlang-reltool
  erlang-runtime-tools erlang-snmp erlang-src erlang-ssh erlang-ssl
  erlang-syntax-tools erlang-test-server erlang-tftp erlang-toolbar erlang-tools
  erlang-tv erlang-typer erlang-wx erlang-xmerl
48 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 37.5 MB of archives.
After this operation, 13.3 kB of additional disk space will be used.
W: Sources disagree on hashes for supposely identical version '1:22.1.6-1' of 'erlang-examples:amd64'.
W: Sources disagree on hashes for supposely identical version '1:22.1.6-1' of 'erlang-examples:amd64'.
W: Sources disagree on hashes for supposely identical version '1:22.1.6-1' of 'erlang-examples:amd64'.
W: Sources disagree on hashes for supposely identical version '1:22.1.6-1' of 'erlang-examples:amd64'.

etc..

How can I solve this issue? I've tried using rm -rf /var/lib/apt/lists/* , sudo apt clean, as well as making a 99fixbadproxy file, but none of these steps have worked.

  • 1
    I would apt-cache policy and view your sources that could be providing the package, and check they are legit, uncompromised & up-to-date. You haven't said what release you are using, but the version doesn't match for any supported release (packages.ubuntu.com/…) so are you using Lubuntu at all? or if you are, I'd check for bad sources/comprised system (where did you download it? Many sites offer Lubuntu but only 1 is official) – guiverc Nov 7 at 5:04
  • fyi: that package version is actually higher than my Lubuntu 20.04 system, so it's not come from an official sources. – guiverc Nov 7 at 5:07
  • I have this error too and these are packages from the Erlang Solutions repository, which should be the most up-to-date. I think the problem is at their end and will hopefully be fixed shortly. – Andrew France Nov 7 at 7:56
  • Currently iam using lubuntu 19.04 . and for the erlang, iam using the official repository, facing this problem, base on Andrew France respond, for a while i remove the repo from software update, so i could update another apt. – Fatoni Nov 7 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.