2

I'm using Ubuntu 18.04.3 Server (i.e. no graphical interface, only terminal) as a virtual machine of VirtualBox. How can I make the numerical keyboard active by default directly after Ubuntu is started up, when I type my login and password (too dreary activate it manually every time)?

3
  • Does this help: askubuntu.com/questions/1184674/… – WinEunuuchs2Unix Nov 6 '19 at 20:44
  • As far as I understand, numlockx works only when graphical interface is available. I have Server version of Ubuntu - no graphical interface. Therefore, your link is useless to me. – Jordan Nov 6 '19 at 21:29
  • you can install numlock , see also # xset --help [options[ ----- i suggest too seeing # man kbd_mode – user643653 Nov 6 '19 at 21:56
0

Please open a terminal window, then run

sudo -i && xhost +SI:localuser:gdm
su gdm -s /bin/bash
gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

then advise, after a reboot of the virtual machine, if NumLock is now on.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.