0

Ok so I rebooted my computer, and something is different... My Wifi connect panel is gone! Seems like I do not have a wifi adaptar anymore!

enter image description here

Weird thing is that using lshw does detect the adaptar...

➜ lshw -C network                            
WARNING: you should run this program as super-user.
  *-network UNCLAIMED       
       description: Network controller
       product: BCM4352 802.11ac Wireless Network Adapter
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=0
       resources: memory:a3400000-a3407fff memory:a3200000-a33fffff
  *-network
       description: Ethernet interface
       product: Ethernet Connection (7) I219-V
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: eno1
       version: 10
       serial: 40:b0:76:de:79:9a
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.5-4 ip=192.168.178.48 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:127 memory:a3500000-a351ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

What is going on?!

UPDATE

➜ sudo dkms build bcmwl/6.30.223.271+bdcom

Kernel preparation unnecessary for this kernel.  Skipping...
applying patch 0002-Makefile.patch...patching file Makefile
Hunk #1 succeeded at 113 with fuzz 1.
Hunk #2 succeeded at 132 with fuzz 2 (offset 1 line).

applying patch 0003-Make-up-for-missing-init_MUTEX.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 111 with fuzz 2 (offset 12 lines).

applying patch 0010-change-the-network-interface-name-from-eth-to-wlan.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 221 (offset -14 lines).

applying patch 0013-gcc.patch...patching file Makefile

applying patch 0019-broadcom-sta-6.30.223.248-3.18-null-pointer-fix.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 2169 (offset 12 lines).

applying patch 0020-add-support-for-linux-4.3.patch...patching file src/shared/linux_osl.c

applying patch 0021-add-support-for-Linux-4.7.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c

applying patch 0022-add-support-for-Linux-4.8.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 2391 (offset 3 lines).
Hunk #2 succeeded at 2501 (offset 3 lines).
Hunk #3 succeeded at 2933 (offset 9 lines).

applying patch 0023-add-support-for-Linux-4.11.patch...patching file src/include/linuxver.h
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 2919 (offset 4 lines).

applying patch 0024-add-support-for-Linux-4.12.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 55 (offset 5 lines).
Hunk #2 succeeded at 472 (offset 5 lines).
Hunk #3 succeeded at 2371 (offset 5 lines).
Hunk #4 succeeded at 2388 (offset 5 lines).

applying patch 0025-add-support-for-Linux-4.14.patch...patching file src/shared/linux_osl.c
Hunk #1 succeeded at 1080 (offset 4 lines).

applying patch 0026-add-support-for-Linux-4.15.patch...patching file src/wl/sys/wl_linux.c
Hunk #2 succeeded at 2306 (offset 4 lines).
Hunk #3 succeeded at 2368 (offset 4 lines).


Building module:
cleaning build area...
make -j12 KERNELRELEASE=5.3.0-20-generic -C /lib/modules/5.3.0-20-generic/build M=/var/lib/dkms/bcmwl/6.30.223.271+bdcom/build...(bad exit status: 2)
ERROR (dkms apport): kernel package linux-headers-5.3.0-20-generic is not supported
Error! Bad return status for module build on kernel: 5.3.0-20-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.271+bdcom/build/make.log for more information.

Could it be that the kernel 5.3.0-20 broke the drivers??

3

If you are using Ubuntu 18.04 with a 5.3 kernel, you will need to do in terminal

wget http://mirrors.kernel.org/ubuntu/pool/multiverse/b/broadcom-sta/broadcom-sta-dkms_6.30.223.271-11_all.deb
sudo dpkg -i broadcom-sta-dkms_6.30.223.271-11_all.deb
Then reboot

|improve this answer|||||
0

your problem could be related to several things.

1) Secure boot

Have you check that the secure boot option is disabled in the BIOS (it could prevent from Broadcom wireless card to be recognized).

2) rfkill

Have you check the rfkill list to see if anything on the hardware or software is preventing you to use your wireless card ? Use this command rfkill list

3) Re-installing the driver bcmwl-kernel-source

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install bmcwl-kernel-source

I'm not sure it will solve your problem but at least it will remove some options of the list. As an alternative, you can find maybe some info here: Installing Broadcom Wireless Drivers

|improve this answer|||||
  • I reinstalled the driver already... As far as my suspicious go... I think it a kernel problem – Enrique Moreno Tent Nov 5 '19 at 22:28
  • Sorry, I did not see your update. If it is related to the kernel, a downgrade of the kernel should be informative. Have you upgrade the kernel recently (before loosing the wifi) ? – dc37 Nov 5 '19 at 22:32
  • Not to my knowledge, but it could have happened without me noticing. I tried with 5.3.0.0-19 and it did not solve it. I tried it with 5.0.0 and it didnt even detect my mouse, so... yeah... – Enrique Moreno Tent Nov 5 '19 at 22:33
  • Damned ! ... I'm out of ideas ... sorry for that – dc37 Nov 5 '19 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.