25

After being forced by Windows to select 'update and shut down'; Windows killed my GRUB menu. I used to have Fedora installed but I removed Fedora and installed Kubuntu some time ago. Suddenly, after the Windows update, my Fedora kernels are listed again in the GRUB. GRUB shows up, just with the wrong kernels from a previous Linux OS. I can boot fine into Windows Boot Manager though. EasyBCD shows the following: "There is one entry in the Windows bootloader."

I already ran update-grub -- no luck.

My partitions are not gone, I can use the rescue terminal fine, and grub.cfg displays something with Ubuntu, so I'm guessing that's OK as well. GRUB stays messed up with the Fedora kernels listed though. I was guessing I had to repair the boot partition using a live USB drive / CD, but I don't know how exactly.

  • 1
    i feel your pain! i've had the same experience! that was the day i gave up on windows. – Woodrow Barlow Nov 7 '19 at 14:22
  • 1
    FWIW if you open the TaskManager ( <CTRL>-<SHIFT>-<ESC> shortcut) you should be able to kill the process that wants you to update & shutdown – Carl Witthoft Nov 7 '19 at 14:30
  • Thanks Carl, turns out you can also delay the updates in settings. However, those things should just work and Microsoft should just make it work. – josh1dev Nov 11 '19 at 13:27
19

Have you tried running Boot-Repair?

It worked for me with a similar issue. This software repairs common issues with boot and grub menu entries. And if it can't solve a certain issue, it outputs a report which you may paste here so that the issue may be understood better.

You may install and run it on Ubuntu through the following commands:

sudo add-apt-repository ppa:yannubuntu/boot-repair    
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

I hope it can work out the issues with kernel entries you described!

  • I managed to fix the problem by running boot-repair. I made sure to run sudo apt install lvm2 before running boot-repair; not doing so will cause boot-repair to fail (for my NVME SSD at least). – josh1dev Nov 5 '19 at 21:01
  • If you're using LVM, check my answer to make sure boot-repair will work without any problems (askubuntu.com/a/1186542/1012884). Thanks for your help clara. – josh1dev Nov 5 '19 at 21:02
12

It might not hurt to run efibootmgr in a Linux terminal to clean out old boot entries. I had a similar issue and wrote a how to on a different forum...

How To Fix: No boot device found.

  • 2
    Thanks, just removed the Fedora entries. – josh1dev Nov 6 '19 at 17:10
5

In my case, when the computer boots I can press the F2 key to get into a system "Setup Utility". Note that this is before any GRUB menu is shown. In the Setup Utility there is a section called "Boot" and there is a list of different boot options, coming from different operating systems that I have installed. In my case, there is one Ubuntu entry, two Fedora entries and one for Windows. (Fedora appears twice because I installed Fedora on two different occasions.) Here is what it looks like for me, the list I'm talking about is in the lower part, under "EFI":

photograph of firmware setup utility

(Note that on your computer it may look different, but with a bit of luck you will have something similar.)

This is great, because it lets me choose which one I want to use, by ordering them, the one on top will be used. In my case I have chosen Ubuntu, which means that I get the GRUB menu created by my Ubuntu installation.

So to fix your problem, try to find the corresponding settings on your computer (could be F2 or some other key you need to press when it boots) and reorder the list of EFI entries to put Ubuntu on top, then you should get the Ubuntu GRUB menu when you boot.

  • 1
    If you are lucky, you will find the right key to press below the computer's maker logo that comes up. It might only show for a few seconds. – crip659 Nov 5 '19 at 19:57
  • 1
    @crip659 Thanks for you response, I've tried this but Ubuntu doesn't show in the EFI menu, unfortunately. Our menu does look the same; except I don't have the ubuntu option. – josh1dev Nov 5 '19 at 20:10
0

A valid alternative, in case it is not possible to start Linux, you can use supergrub disk to start linux, and then from there install grub-customizer and rearrange the mbr

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.