2

I just installed Ubuntu (version 18.04.03). I noticed that blue is being rendered as purple. Further that this only happens on some applications. In GIMP (image editor) the color rgb(0,0,255) renders as the expected blue. However in the following apps, the same image appears purple:

  • Chrome
  • Firefox
  • Image Viewer
  • Probably other apps, haven't tested all

In these applications, the image renders correctly:

  • GIMP
  • File Browser
  • Sublime Text
  • Probably other apps, haven't tested all

In this previous question, the culprit was "Night Light" mode. However on my computer this is off. Enabling it turns the screen distinctly orange-ish.

The fact that blue renders correctly on GIMP (an image editor where color fidelity is important), leads me to believe it has something to do with a setting similar to Night Light mode...

How can I turn off whatever "feature" is causing this color change?


Update:

Here are some photos. It is hard to capture with a camera, but the Image Viewer (left) renders the blue test image distinctly purple, whereas GIMP (right) does not.

Also interesting is that the GIMP render remains the same shade of blue regardless of the viewing angle. Whereas the Image Viewer's shade of purple changes with the viewing angle. Looking down at the screen from the top, it is a distinct purple. Whereas looking up at the screen from the bottom, the purple almost looks like the blue it is supposed to be.

The moire pattern observed in the Image Viewer is not visible to the eye. However, maybe it is related to the color change depending on viewing angle effect...

Top view: top angle

Bottom view: bottom angle

5
  • Related: askubuntu.com/questions/9443/… – pLumo Nov 5 '19 at 7:12
  • Either calibrate your monitor using a calibration device or see if you can find an ICC profile fitting your monitor. Make sure you reset your monitor to default settings. – pLumo Nov 5 '19 at 7:14
  • @pLumo The same effect is observed regardless of the screen I use. I have tried three different screens with the same result. – Jet Blue Nov 5 '19 at 7:54
  • 1
    Please test with a live drive 'Try Ubuntu without installing' of Ubuntu 18.04.1 LTS with the md5sum:f430da8fa59d2f5f4262518e3c177246 *ubuntu-18.04.1-desktop-amd64.iso Does it work correctly? What graphics driver are you using? And what graphics chip: brand name and model? – sudodus Nov 5 '19 at 8:25
  • @pLumo Thank you for pointing me towards colour profiles. I turned off "Device Colour Profiles" and this seems to have resolved my issue. – Jet Blue Nov 6 '19 at 8:03
3

Turning off color management seems to have resolved the issue. The setting can be found at:

Settings → DevicesDevice Colour Profiles

A restart is required to see the changes.

0

On Ubuntu 20.04 head to Color in Settings and turn it off. Worked for me.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.