I have 2 computers, a desktop computer and a laptop. Both have a dual boot, with Windows 10 and Ubuntu 19.10.

My printer is a Xerox WorkCentre 6015B.

Everything worked well with Ubuntu 19.04 and before also (I use Ubuntu since 12.04). I configure exactly the same way on both computers and now I get the same error message on both computers saying:

Requires authentication / Credentials required in order to print.

The printer works with Windows 10, so I think there is not a problem with the printer. I created a live USB with Ubuntu 19.04, and I can configure the printer and I can print. So this comes from Ubuntu 19.10 I believe.

The error message says "requires authentication", but I don't know which username or password I need and where to put them. Before Ubuntu never asked me to authenticate. Do you think it could be a bug? Have any of you encountered the same problem?


I’ve had this same issue with Pop!_OS (an Ubuntu-based distro) after upgrading to 19.10. At my workplace we print via a print queue with two printers. When I configured the printer in Pop!_OS 18.04 I remember that I needed to enter a username/password set up by the IT team only once. After updating to 19.10 I see this notification appear but that takes me to the print queue where I could do nothing, which seems to be the same problem.

To solve it I stopped CUPS: sudo service cups stop

And then edited the file /etc/cups/printers.conf (you’ll need root access). Look for your printer (usually the <DefaultPrinter ...> block) and look for the line that starts with AuthInfoRequired. In my case it was AuthInfoRequired none and I changed it to AuthInfoRequired username,password.

After that I restarted CUPS: sudo service cups start

And after sending a job to the printer, I had this printer authentication dialogue window show up. I entered the username/password, clicked on “Remember password” and this fixed it for me.

I hope that helps.

Also, it might be worth comparing to the previous configuration files, I think they are kept in /etc/cups with a .0 extension. Unfortunately I had already messed with them and I lost the original ones. I suspect that the issue must be there.


Thank you very much. As I do not have Ubuntu 19.10 installed on my computer, I use a Live-USB. I followed all the steps and indeed, I get a printer authentication dialogue window. The username is already written (ubuntu) and it asks for a password. I leave it empty and press enter, but it does not print. Which password should I use ? I could install Ubuntu 19.10 again on my computer, but if I do it but that it doesn't work, it would be time wasted.

Anyway thank very much for your answer again. Hope you can answer my new questions.


  • Unfortunately that’s a printer-specific setting. I’d double-check that you don’t have any authentication set up, in which case AuthInfoRequired none would be enough. Also, I’d try to set a username/password on the printer and use that in the authentication dialogue window. I’m afraid I can’t provide any further advice since the printer in my workplace is fully managed by the IT department.
    – Alf
    Nov 27 '19 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.