1

This is my first time (please be gentle) using Linux.

I have just received a clean install of Ubuntu 18.04 LTS (without graphical interface) with just SSH added on a remote server.

I am currently trying to enable remote desktop to this server using SSH commands. (I have received username (root) and password for SSH - I am trying to use these while logging into remote desktop.)

As of this time I added all of the 4 repositories (main, universe, multiverse, restricted), successfully installed xrdp and Xfce 4 using the tutorial How to use xRDP for remote access to Ubuntu 14.04 (well at least I think it was successful).

My problem now is, that after establishing connection via Remote Desktop Manager (on my Windows 10) I see this:

xrdp login screen

And after filling out the username and password I see this:

connection log window

The message says:

Connection Log

connecting to sesman ip 128.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
login failed for display 0

I tried to troubleshoot using this guide: 18.04.3 LTS XRDP "login failed for display: 0" using these lines of code:

sudo apt-get install xserver-xorg-core
sudo apt-get -y install xserver-xorg-input-all

But to no avail.

What went wrong? What does it mean that that the login failed for display 0?

3
  • If the remote Ubuntu server does not have a monitor attached to it you might need to setup a fake display for it to work properly. askubuntu.com/questions/453109/… – Terrance Nov 4 '19 at 0:30
  • Did that and rebooted. Nothing changed. – Peter Nov 4 '19 at 1:55
  • If you installed Ubuntu without a graphical interface, can you go back and install Ubuntu with a graphical interface? You really want that as a base for remote graphical logins, even if you don't need to be able to log in locally. – tripleee Nov 4 '19 at 9:11
1

I solved this by clicking on edit in the rdp login screen. Then click on More Choices, and you'll be able to select your microsoft account, where you can enter your ubuntu creds.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.