1 Starting points and intents

I wish to have the Windows/MSDOS fonts installed in my Ubuntu 18.04, installing the package ttf-mscorefonts-installer (3.6ubuntu2).

2 Ubuntu 18.04

2.1 The Synaptic way

After launching the installation of ttf-mscorefonts-installer, I am asked for acceptance of the EULA license

Configuring ttf-mscorefonts-installer

The following message makes me think that all is fine:

Changes applied

Instead, shortly afterwards, I am presented with this one which betrays my expectations:

enter image description here

If I click on 'Run this action now' there is another windows asking for authentication for /usr/lib/update-notifier/package-data-downloader. If I proceed, the screen is greyed out but the application does not seem to proceed within any reasonable time. I can cancel the operation, but I am unable to fix the problem

2.2 The terminal-based way

2.2.1 sudo apt install ttf-mscorefonts-installer

Repeating the same from the terminal, the interesting part of the input is

/usr/lib/msttcorefonts/update-ms-fonts: 87: /usr/lib/msttcorefonts/update-ms-fonts: cabextract: not found

repeated 11 times, and

mv: cannot stat 'andalemo.ttf': No such file or directory

repeated 30 times for the fonts andalemo, ariblk, arial, arialbd, arialbi, ariali, comic, comicbd, cour, courbd, couri, courbi, georgia, georgiab, georgiai, georgiaz, impact, times, timesbd, timesbi, timesi, trebuc, trebucbd, trebucit, trebucbi, verdana, verdanab, verdanai, verdanaz, webdings.

The concluding remark is

One or more fonts could not be extracted. The fonts are NOT installed. Please run 'dpkg-reconfigure ttf-mscorefonts-installer' to perform the installation again

2.2.1 dpkg-reconfigure ttf-mscorefonts-installer

Launching the above command, first I get this window about font files location:

enter image description here

I leave the line blank since the fonts have presumably not been downloaded (not extracted, not found).

Second, this other window on mirror repository

enter image description here

where I again leave the line blank trusting that the system is informed about where to fetch the material.

The command is completed with exit status 0, but there is no messaging about what happened.

2.2.3 sudo apt install ttf-mscorefonts-installer take 2

Reading package lists... Done Building dependency tree
Reading state information... Done ttf-mscorefonts-installer is already the newest version (3.6ubuntu2). 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

At this point I don't have a benchmark to know whether the installation has been complete and successful. In /usr/share/fonts/ I cannot find the ttf files mentioned above in 2.2.1: find -name verdana.ttf produces no match in both /usr/share/fonts and $HOME


  • How can I be sure that the installation has been terminated successfully?

  • Where are the fonts supposed to be fetched from (remotely) and saved into (locally)?

Knowing this is important for triaging other issues down the line; more later in a different post.


I have seen in another computer with Ubuntu 14.04 and ttf-mscorefonts-installer 3.4+nmu1ubuntu1 that the fonts in points have actually been stored in /usr/share/fonts/truetype/msttcorefonts/. So I imagine that now there must be something wrong with sourcing and saving these files.


1 Answer 1


It appears that ttf-mscorefonts-installer is not properly installed.

Run the following commands to reinstall the package:

sudo apt update
sudo apt install --reinstall ttf-mscorefonts-installer

Now, when you get to a screen that asks you to select <OK>, press TAB to highlight <OK> and then press the SPACEBAR to select the highlighted item and/or then press ENTER to continue.

Follow the same process for any screen that asks you to select <OK>.

Then, check the /usr/share/fonts/truetype/msttcorefonts/ directory to verify the install.

If that doesn't work, purge the package and reinstall it:

sudo apt purge ttf-mscorefonts-installer
sudo apt update
sudo apt install ttf-mscorefonts-installer

Follow the same process described above to select <OK> when prompted.

On my system, it is installed correctly. The files are downloaded to /usr/share/fonts/truetype/msttcorefonts/ and when I run: sudo dpkg-reconfigure ttf-mscorefonts-installer nothing happens.

Also, when I run sudo apt install --reinstall ttf-mscorefonts-installer, I get no errors and the message eventually says:

Preparing to unpack .../ttf-mscorefonts-installer_3.6ubuntu2_all.deb ...
mscorefonts-eula license has already been accepted
Unpacking ttf-mscorefonts-installer (3.6ubuntu2) over (3.6ubuntu2) ...
Setting up ttf-mscorefonts-installer (3.6ubuntu2) ...
Processing triggers for update-notifier-common ( ...
Processing triggers for fontconfig (2.12.6-0ubuntu2.3) ...

Not the answer you're looking for? Browse other questions tagged .