8

On Ubuntu 19.04 I had current rtl8812au (AC1200) and rtl8814au (AC1750) dkms drivers for my USB wireless dongles installed and running fine.

They both broke after I upgraded to Ubuntu 19.10.

I've been able to find a replacement/newer rtl8812au driver that works with kernel 5.3 on Ubuntu 19.10.

I haven't been able to find a replacement/newer rtl8814au driver that works with kernel 5.3 on Ubuntu 19.10.

Github.com has a number of rtl8814au drivers available, even some that pro-port to compile with kernel 5.2. I believe that I've tried about 6 different rtl8814au drivers from github, but none of them work, even though some of them do compile with kernel 5.3.

Does anybody know of a working rtl8814au driver that works with kernel 5.3 on Ubuntu 19.10?

20

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo ./dkms-install.sh

It worked for me on my rtl8814au device, it should work for rtl8812au, rtl8814au, and rtl8821au devices. For some strange reason the driver didn't want to work until after a second reboot. I don't know why

Secure boot needs to be disabled in BIOS, check results for mokutil --sb-state

| improve this answer | |
  • That seems to work! Thanks! – heynnema Nov 3 '19 at 22:33
  • This also works for my TP Link T2U Nano (id 2357:011e) on kernel 5.3.0-24, it uses the 8821 driver. Thanks! – Daniël Knippers Dec 11 '19 at 17:38
  • Additional step: sudo modprobe 88XXau. Driver works for me. Thanks! – Amedee Van Gasse Dec 16 '19 at 9:11
  • Can confirm this works even with 18814au device. Dongle lit up instantly (without needing modprobe). – crypdick Feb 20 at 17:08
  • Tested this with Linksys AC1200 Dual bank Wireless-AC USB Adapter (RTL8812AU). Bus 001 Device 004: ID 13b1:003f Linksys WUSB6300 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU] Worked like a charm. I am on Ubuntu 18.04 LTS (Kernel: 5.3.0-42-generic) – Muhammad Shahab Mar 21 at 20:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.