15

My laptop with Ubuntu 19.04 detected and set my HDMI output on every boot. But since I upgraded to 19.10, I need to set it manually every boot as follows:

From

before

to

after

I already tried every single solution proposed in How do you set a default audio output device in Ubuntu 18.04?, but apparently there's something different in 19.10. What I did specifically:

  1. pactl
$ pactl list short sinks
9   alsa_output.pci-0000_00_1f.3.hdmi-stereo-extra1 module-alsa-card.c  s16le 2ch 48000Hz   SUSPENDED

$ pactl set-default-sink 'alsa_output.pci-0000_00_1f.3.hdmi-stereo-extra1'
  1. Add either the device number and device name in /etc/pulse/default.pa like:
set-default-sink 9

and

set-default-sink alsa_output.pci-0000_00_1f.3.hdmi-stereo-extra1

and

set-default-sink 'alsa_output.pci-0000_00_1f.3.hdmi-stereo-extra1'
  1. Comment the line load-module module-switch-on-connect.

  2. Switch profiles in PulseAudio Volume Control to HDMI2.

None of these persisted after reboot.

1
  • see updated answer below to comment out "switch on available" option. Nov 8, 2019 at 23:04

2 Answers 2

14

This is a bug reported here three days ago:

PulseAudio reverts the sound to HDMI all the time when a HDMI related power event occurs. That means, although I have set another USB sound device plugged in and set as default under sound settings, when an application like Kodi or the system shuts off the HDMI monitor and I reactivate the monitor, the sound is set to HDMI output again and again.

That probably has to do with the fix to the reported Bug # 1711101 and definitely not happened at Ubuntu 19.04. I switched to Ubuntu 19.10 two days ago.

Setting the USB device as default does not help, even when done by PulseAudio mixer (gui) and removing HDMI output from the alternatives option.

Only one person is effected by the bug (on November 4, 2019). Visit the link, click that it effects you and subscribe to the bug email.

11 people are now effected as of November 8, 2019. Comment #11 presents a solution though:

I think i found a solution. I'm commenting this lines

#load-module module-switch-on-port-available
#load-module module-switch-on-connect

in etc/pulse/default.pa and all work for me.

5
  • 2
    Commenting the two lines in default.pa also disables switching on plugging in headphones, which is a deal breaker for me. There seems to be a fix under way though: bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1847570
    – fohswe
    Jan 1, 2020 at 17:01
  • 1
    Why can't Ubuntu/Debian just send the audio to every available output, like Windows always did?
    – Rodrigo
    Apr 7, 2020 at 15:35
  • @Rodrigo It might be possible to send sound output to multiple devices at the same time. Why don't you post that question? Apr 8, 2020 at 0:19
  • @WinEunuuchs2Unix Thank you, I will.
    – Rodrigo
    Apr 8, 2020 at 0:22
  • 1
    The problem came back after upgrading to 20.04 and I had to comment these lines again.
    – bwdm
    May 8, 2020 at 0:49
0

Looks like the fix for https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1847570 was published as a part of pulseaudio/eoan which can be upgraded via sudo apt-get upgrade pulseaudio/eoan. This fix seems to be working for me as well as commenters on that post without the changes required for commenting out the lines suggested by WinEunuuchs2Unix

1
  • doesn't work on 20.10. E: Release 'eoan' for 'pulseaudio' was not found Commenting the lines out in the accepted answer fixes this problem for me.
    – Partack
    Jun 4, 2021 at 2:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.