I upgraded to Ubuntu 18.04. Since then, I am able to access Internet only through Tor browser. Before the upgrade, I could access Internet using a normal Chrome/Firefox browser without involving Tor. How to fix this?

  • 2
    Have you tried changing proxy setting in the browser chrome & firefox? Try "No proxy" or "Bypass" (Default is: System wide settings)
    – user.dz
    Nov 2, 2019 at 22:22
  • 1
    Yes. I did that but still cannot access without Tor.
    – Jay
    Nov 7, 2019 at 8:48
  • 2
    did you check firewall settings? Probably http / https are blocked (80 and 443)
    – damadam
    Nov 7, 2019 at 9:02
  • 2
    Have you tried other OS on the same network? Maybe your phone or something else? Maybe something else changed? Nov 7, 2019 at 10:34
  • 1
    <br> try this. <br> Looks quite similar. Nov 10, 2019 at 10:44

2 Answers 2


Did you try to add Google servers? That's a hard reset I do sometimes after updating NordVPN I cannot access the internet neither Chromium or Firefox but Telegram works perfectly fine, like what a hack... There's a hard reset I use by overwriting resolv.conf

sudo nano /etc/resolv.conf

delete what is inside and add


Save it and close. Resolv.conf gets overwritten all the time by your system environment so you won't do much damage to the network it more likely will produce debug effect.

Now run

sudo systemctl restart NetworkManager.service

Or click switch On / Off network icon.

You can find lots of variants in this old thread as well as similar to my way of workaround above and use it as a fix.


You may have an incorrectly configured Internet connection, so you are experiencing problems with the Internet.

Tor when installed downloads a number of packages torsocks lynx and may be some others installed by you that affect the quality of the connection.

To resolve the situation, you need to do the following.

  1. Make sure that the output of ifconfig or ip addr shows the correct settings.
  2. Remove all packages related to the Internet.
  3. Make sure that the contents of /etc/resolv.conf correct 4. Check how the Internet is configured on the system, and if you use a network Manager or any other connection Manager, try to remove them and configure a static connection.
  4. Reinstall browser
  5. Check your gateway or router
  6. Reboot pc.

Also, here duplicate question? No internet after upgrade from 16.04 to 18.04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .