31

I'm using gnome-shell on Ubuntu 12.04. When I hit PrtSc to take a screenshot, it works, but it automatically saves the screenshot in my Pictures folder. There's no dialogue asking where to save. It does show the dialogue box under unity though.

30

Assuming that I have read this bug-report correctly...

This is by design. No really!

Comments #37 onwards talk about this.

The current unity patches state:

on Unity sessions display a confirmation dialog after taking screenshots with the keybindings, the auto saving behaviour is confusing our users

The thread carries on:

but your fix doesn’t help when I don’t use Unity. Why did you think this only applies to Unity users?

With the reply:

because we keep being asked by GNOME upstream and GNOME user to let their desktop alone and ship it as designed so that's what we try to do, we stick to upstream behaviour for GNOME environments and take design decision for Unity

So there you have it. The Gnome-Developers are insistent that their desktop environment should behave this way. Its an upstream issue. The Canonical Developers are respecting this decision and hence the "divergence" - Unity users have the Save as dialog whilst gnome-shell users have the by-design no dialog functionality.

Thus if you are using gnome-shell/gnome-classic, all the screenshots are saved in your home pictures folder ~/Pictures

Note: You can override the screenshot location with gsettings (command-line) or dconf-editor (GUI):

  • set the org.gnome.gnome-screenshot auto-save-directory to file:///home/yourusername/wherever/you/want
|improve this answer|||||
  • 3
    is it possible to make gnome-screenshot automatically save without showing dialog ? – hingev Mar 28 '13 at 6:28
  • 1
    The lack of the printscreen dialog in bionic is a big inconvenience. It's not just about being able to save screens to an arbitrary location/filename. Even more important was being able to copy a printscreen into a clipboard without saving it to a file: just copying it and Ctrl+V into IM, email client or any (web)app. Now I have to take additional steps to open file manager, navigate to the Pictures folder, locate the file I need among other ones, and drag&drop it to where I need it, then, delete it. The functionality and user experience has decreased significantly, is annoying. – Kris Jace Jun 11 '18 at 1:55
6

I'm late to the party, but I just tripped over this and want to offer a slightly different answer.

Basically, in the latest Gnome 3 / Gnome Shell then they are no-longer using Gnome Screenshot. That means any changes to Gnome-Screenshot's default settings (like default save location) won't affect anything.

Instead, you need to go to your Keyboard settings, disable the "Save a screenshot […] to Pictures" shortcuts and add your own custom shortcuts that call gnome-screenshot with no args (auto-save to its gsettings-defined location), -a (save area), -w (save current window) or -i (if you want the options dialog back). You can obviously mix-and-match some settings, or add more from man gnome-screenshot.

|improve this answer|||||
4

try using Shutter instead, its the best screen capture tool (as it site says :)

sudo add-apt-repository ppa:shutter/ppa    
sudo apt-get update && sudo apt-get install shutter

app site: http://shutter-project.org/

To configure Shutter as the default tool to take screenshots with when you press PrtSc or Alt+PrtSc, here’s what you need to do:

gnome:

1 Go to Edit ▸ Preferences in Shutter
2 In the Keyboard tab, enable both the “Capture” and “Capture with selection” checkboxes:
3 That’s it! Now the usual PrtSc and Alt+PrtSc keybindings will use Shutter to take the screenshots.

|improve this answer|||||
0

Hey guys this might help, I was poking around in the gnome menu as I noticed that with the new version of shutter enabling the hot key was not as simple and found that the iBus daemon wasn't started on my machine while in 'gnome fallback'. I found this by going to the gnome menu > system tools > Preferences > Keyboard Input Methods. I clicked it and started it as requested by a dialog and now printscreen works. Although the dialog used in unity doesn't show up, I found that it saved into ~/Pictures by default so no biggy, hope I could help someone as this frustrated me as well.

|improve this answer|||||
0

Maybe someone finds this helpful: To get this feature back, i copied the v3.18.0 binary to /usr/bin/gnome-screenshot, disabled the system hotkey for "Save a screenshot of an area to pictures" and created a new shortcut with the command /usr/bin/gnome-screenshot -a -i

Downside: without -i i can only select an area that will be copied to the clipboard (already better than before), with the switch, i first get the gnome-screenshot options before i can select the area, but the rest is fine.

For full screenshot, drop the -a

(building v3.18.0 under ubuntu 18 is a bit messy, i ended up with something like

  • start a ubuntu 16.04 docker container (dont forget to mount something like -v /tmp:/tmp so you can copy the binary to your host system in the end)
  • enable backports, apt-get update
  • install: apt-get install git gnome-common libx11-dev libglib2.0-dev libgtk-3-dev libcanberra-gtk3-dev
  • ./autogen.sh && make && cp ./src/gnome-screenshot /tmp/
  • leave the docker container, overwrite /usr/bin/gnome-screenshot with file in /tmp

Be aware doing this is actually a semi-nice idea, even though it seems to work fine on my machine, the binary may be linked against symbols that dont exist on ubuntu 18 anymore / behave different. (I think the main proble why i compiled it in a 16.04 container was an version conflict in libpcre)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.