10

On Ubuntu 19.04 I had current rtl8812au (AC1200) and rtl8814au (AC1750) dkms drivers for my USB wireless dongles installed and running fine.

They both broke after I upgraded to Ubuntu 19.10.

I've been able to find a replacement/newer rtl8812au driver that works with kernel 5.3 on Ubuntu 19.10.

I haven't been able to find a replacement/newer rtl8814au driver that works with kernel 5.3 on Ubuntu 19.10.

Github.com has a number of rtl8814au drivers available, even some that pro-port to compile with kernel 5.2. I believe that I've tried about 6 different rtl8814au drivers from github, but none of them work, even though some of them do compile with kernel 5.3.

Does anybody know of a working rtl8814au driver that works with kernel 5.3 on Ubuntu 19.10?

  • All I can say is that the same thing has happened to me in the past. But then it goes away, a day or so later, without my doing anything about it. – Justice for Monica Nov 2 at 7:46
  • This is indeed network issues, either issues to connect to the server or issues with the server itself. (Temporarily) changing to another mirror server may help. – vanadium Nov 2 at 12:22
8

As others have mentioned, the problem is the network (teksavvy/rogers). Seems they're blocking the User-Agent that apt-get uses by default. I wiresharked the requests, and was getting a slew of TCP retransmissions. To fix the problem, change the apt-get user-agent, by adding the following to /etc/apt/apt.conf.d/99user-agent

Acquire
{
  http::User-Agent "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.110 Safari/537.36";
};

This is from https://dmfrsecurity.com/2018/12/10/changing-apts-user-agent-string

  • Yes, this works and is the temporary solution. – user1011755 Nov 2 at 16:48
  • Thank you for this! I've just spent half my weekend trying to troubleshoot this exact issue on a Raspberry Pi I'm setting up for a software dev project. I've asked TekSavvy for more info, and linked back here: twitter.com/jfuerth/status/1190746063059214336 – Jonathan Fuerth Nov 2 at 21:49
1

Same issue over here. I just put my pfsense box in a VM so I thought that was it. I restored the physical machine, but same issue. I've connected my ubuntu machines directly to the modem and the issue persists. Looks like the router isn't the issue since I can bypass it entirely. Using my phone as a wifi hotspot, and the issue goes away.

Seems like an ISP issue. Is this possible? I'm in Canada for what it's worth.

  • 1
    It might be something to do with ISPs, perhaps Canada. Or at least Ontario. I'm having the same issues. When I use VPN, problem goes away. – klimaat Nov 2 at 15:18
  • 1
    Ontario here as well, SW of Toronto. Teksavvy, which is a rogers reseller. I think we're narrowing it down. – Maclargehuge Nov 2 at 15:26
  • Anything with "Debian APT" is blocked. Try curl -vL -A "Debian APT" www.google.com and gets stuck – user1011755 Nov 2 at 15:40
  • 2
    I've sent an email to teksavvy. Given that it'll get lost in the realms of tier 1 tech support, I'm not hopefuly we'll get a reply any time soon. – Maclargehuge Nov 2 at 15:58
  • 1
    Seems to be working as of this morning. Perhaps thanks should go to @Maclargehuge – klimaat Nov 3 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy