5

I recently updated from Ubuntu 19.04 to 19.10 and noticed the multimedia keys such as Play and Stop stopped working in Kodi. Whenever I press a multimedia key, it only shows a big crossed circle icon (also in desktop). I tried to enable/disable the shortcuts for the multimedia keys, but it didn't work. I also cannot create a new shortcut with the multimedia keys, because the big icon already appears when pressing the key. I'm no more sure if I had to disable or enable the shortcuts in 19.04 though.

I'm not sure, if it is related, but the Ubuntu upgrade finished not clean. It ended in console and I had to reset my PC. However everything seems to work correctly besides the multimedia keys.

Any help would be appretiated.

8
  • A definitive test would be to boot from a LiveUSB made from a 19.04 ISO and testing for multimedia key function; then, repeat the test with a LiveUSB made from a 19.10 ISO. Please run those tests, and let us know the result by clicking edit and adding the results to your question. – K7AAY Nov 1 '19 at 20:07
  • 1
    @K7AAY I'm also having this issue. I also upgraded from 19.04 to 19.10 but my upgrade worked just fine. The media keys used to work fine on 19.04 and they also work on the live USB for 19.10. – Topo Nov 13 '19 at 9:18
  • @Topo Not sure if this also applies in this case, but try language support (from menu) -> input method -> change from Ibus to none, restart. Not a fix, but at least a work around. Please mention if it works. If it does, I'll make it an answer. – Jacob Vlijm Nov 13 '19 at 20:51
  • It didn't work for me @JacobVlijm :( Radim did it work for you? – Topo Nov 18 '19 at 22:38
  • Shoot @Topo, sorry to hear. – Jacob Vlijm Nov 18 '19 at 22:40
1

It is a bug/a missing issue of the new software.


It is not an issue with detecting multimedia keys but with connecting the key function with the action.

That is, the desktop recognizes multimedia key (as it shows the ban symbol) and could perform that action (play, stop, next, etc.) but there is not target in which direct it (there is no application registered).

Ultimately, with the upgrade, some component of the desktop does not act more as connector and this id the reason why your fix do not work

enable/disable the shortcuts [...] didn't work


look for mpris if you want to grow your knowledge

3
  • Any tips to get it working again? – Topo Nov 18 '19 at 6:03
  • Try to open a bug upstream to understand if it was intentional or it is a bug – mattia.b89 Nov 18 '19 at 7:45
  • This thread may also be relevant to your purpose: askubuntu.com/questions/1186160/… – yktoo Jan 1 '20 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.