38

Since I upgraded to Ubuntu 19.10 my system freezes/lags regularly. The mouse, keyboard and screen are completely stuck, after a few seconds it "unfreezes" again. Sometimes it repeats the input I did. For example if I type "F" in a text field it shows "FFFFFFFF" afterwards.

I seems like a lag is triggered every time the system has to read and write a larger amount of data (e.g. start new program, load new firefox tab).

I completely reinstalled Ubuntu 19.10 again on my machine but it is still the same. It runs on a Dell XPS 13.

The same problem is described but not answered in this posts:

Ubuntu 19.10 cursor freezes randomly

Mouse and Keyboard Freeze

Because it was asked in the other posts here are may gnome extensions: enter image description here

EDIT: Thanks for the comment!

  1. I do not use a PS/2 mouse or keyboard.
  2. The model: Dell XPS 13 9360 (2016 version). On the label it says: Reg Mode: P54G Reg Type No: P54G002

EDIT2: Turning off all extension does unfortunately not solve the problem.

Edit 3: Here is what it looks like in the system monitor when I reload a website. The Network manager

Edit 4: Thank you for your comments! Before I reinstalled Ubuntu 19.10 my swap had 8 GB.

enter image description here

Edit: 6 Increasing the swap to 8GB (I have 8GB of RAM) and setting the swappines to 10 seems to have done something. I will have a further look into it.

Edit: 7 My Bios version is 2.10.0. I'll check of updates.

The Disk utility does not show the SMART data for my ssd.

  • 1
    1) Do you use a PS/2 mouse or keyboard? 2) Please flip the laptop over and look for the serial number sticker. There's a model number there. What is that model number? There are thirteen different XPS 13 models dell.com/support/search/us/en/… made by Dell, knowing the right one could help... Please click edit and put answers to 1 and 2 in your question. Please do not use Add Comment; use edit instead. – K7AAY Nov 1 '19 at 15:28
  • 1
    One thing you could try is to disable all GNOME extensions, see askubuntu.com/q/1029376/874649 -- does the problem still appear when they are disabled? – Elias Nov 1 '19 at 15:42
  • 1
    Edit your question and show me free -h and cat /etc/fstab and sudo sysctl vm.swappiness. Your swap is too small. Start comments to me with @heynnema or I'll probably miss them. – heynnema Nov 1 '19 at 16:09
  • 1
    Testing with all extensions disabled indeed is one of the first things to do. Also, run "top" to see which processes are loading the system. Swap indeed is small, but will not be the cause why the system with 8 GB is lagging. – vanadium Nov 1 '19 at 19:39
  • 1
    Setting vm.swappiness=10 is wrong for 8G RAM and 1-8G swap. Set swap to 4G, and try vm.swappiness=70 or 80. Check BIOS version with sudo dmidecode -s bios-version and then check dell.com for an updated BIOS. Report back. – heynnema Nov 2 '19 at 14:02
18

This is a regression that happened from Kernel from Kernel 5.0 to 5.3. This may be a problem in the recent changes that the 5.3 kernel introduced with the deprecated deadline, cfq and noop, which according to the Ubuntu wiki "prior to Ubuntu 19.04 with Linux 5.0 or Ubuntu 18.04.3 with Linux 4.15, the multiqueue I/O scheduling was not enabled by default and just the deadline, cfq and noop I /O schedulers were available by default". It has also been reported that some bugs have been introduced for those who have an intel and use the i965 driver.

To get around the problem i changed the swappiness kernel parameter to 10, and use bfq for IOSchedulers, by default Ubuntu uses mq-deadline.

|improve this answer|||||
  • I changed this to the new accepted answer because it makes sense that this is the underlying reason. I think updating the video drivers will work as well. – Philipp Nov 18 '19 at 9:43
  • I've updated to kernel 5.4RC8 and it seems the freezes are less/gone. – localhost Nov 21 '19 at 16:06
  • 1
    It’s not just the Xserver, I was getting freezes on Wayland also. – darksky Nov 21 '19 at 19:44
  • Upgrading kernel from 5.3.0-23-generic to 5.4.1-050401-generic helped. Looks like freezes are gone. – Justas Dec 5 '19 at 7:34
  • 1
    Upgrading to kernel 5.4.0 didn't help. I'm upgrading to 5.4.12, will come back in a couple of days reporting whether it helped or not. – Patryk Cieszkowski Jan 16 at 1:36
3

After update to ubuntu 19.10 I also get lags and freeze. Not sure this helps you, but my problem was in graphics drivers. I update drivers from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers and it works again.

First time i also think this was ssd problem because lags frequently occur when start new application or switch firefox tab.

|improve this answer|||||
  • Is it easy to uninstall 100% and go back to default drivers if wanted? Like to have as clean installation as possible but if this helps I might give it a try. – Pal Bergstrom Nov 14 '19 at 12:15
  • @PalBergstrom As indicated on the Launchpad page : "=== Revert to original drivers === To revert to standard Ubuntu drivers type the following in a prompt shell: $ sudo apt-get install ppa-purge $ sudo ppa-purge ppa:oibaf/graphics-drivers" – mhr Nov 18 '19 at 16:25
3

I had a similar issue. I get temporary relief from turning swap off with sudo swapoff -a. It may be related to the usage of swap in the new kernel.

It seems this is a confirmed bug and is being investigated here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1833281


I managed to significantly reduce this problem in Ubuntu 19.10 by upgrading my kernel to 5.5.9. What I did:

  • I went to https://kernel.ubuntu.com/~kernel-ppa/mainline/ and found the latest release of 5.5 after sorting by Last Modified.

  • Under Build for amd64 succeeded, I downloaded four files: linux-headers-...-all.deb, linux-headers-...generic, linux-image-...generic, and linux-modules-...generic.

  • Then I put them in a directory, went to terminal, cd'd to that directory, and ran sudo dpkg -i *.deb

That's all it took. It automatically installed the latest 5.5 kernel and created a grub entry that became the default. After a restart, no more lags or freezing mouse, at least they became more rare. Swap works normally again.

|improve this answer|||||
2

I had the same issue (also with a Dell XPS13). Updating the graphics drivers with the ones from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers like @daa did resolved the issue for me too.

|improve this answer|||||
  • 5
    I feel weird about installing third party drivers. Who is oibaf and why is his driver not in the main release or from an official site like Intel? – darksky Nov 15 '19 at 2:21
  • I have the same question as darksky – Pal Bergstrom Nov 15 '19 at 13:42
  • Oglaf's been around quite a long time. I've used it several times with good results. In one case, due to bugs in stock driver; in a few cases becasue "slightly newer mesa3d than ubuntu comes with" had some huge speedups. Ubuntu is very conservative in updating their drivers, problems like this stuttering are very unusual on it. Why isn't oglaf default? It's bleeding edge; in this case, bleeding edge solves problems but in other cases, bleeding edge adds bugs and problems. – user153822 Feb 28 at 3:14
1

Kubuntu 19.10 also has this problem. Periodic freezes of the system for 1-2 seconds. This is observed during i/o operations. When swap is disabled, freezes is significantly reduced.

|improve this answer|||||
1

I migrated to ubuntu 19.10 and got : - mouse lags and freeze, frequently around 12 seconds ! - 100% cpu usage on one core - click on web browser's tab = freeze

I have an Assus SonicMaster computer, Core i5, Nvdia Gforce 940M.

Solution: I went for : Softwares & Updates > Additional drivers It shows : X.org activated.

enter image description here

Then changed to activate proprietary drivers.

enter image description here

So far so good. No more lags.

|improve this answer|||||
  • 4
    Hmm. I don't see any additional drivers. Could be because I only have UHD Graphics 620. – Pal Bergstrom Nov 15 '19 at 13:22
1

Same issue on a Dell XPS 13 9343 (see this post).

One way to make things better was to reduce swap size to 4 GB (for 8 GB of RAM) and set vm.swappiness to 80.

|improve this answer|||||
1

I had similar issue after upgrading to 19.10 on my Dell XPS 13 9350

Since @stickway helpfully identified this is a kernel bug I purchased this tool to manage kernels in Ubuntu and upgraded to 5.4.1 https://teejeetech.in/ukuu/

I am not affiliated in any way with this tool or it's author, however it seems to work well for me so I wanted to share in case it may be of help to anyone else.

MASSIVE WARNING: Obviously newer kernels are not yet officially supported, if you want to be safer you should downgrade to a previous kernel instead.

|improve this answer|||||
0

Problem still persist with recent kernel 5.3.0-40.

I downgraded to 5.2.21 from https://kernel.ubuntu.com/~kernel-ppa/mainline/ and lagging and microfreezes are gone, system is running fine and generally is more responsive. Did not try upgraded kernel though.

Microfreezes are caused by swapping and general during disk write operation. Fiddling with swappiness and swaps size helps just a little, it is not a solution.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.