3

Today I have decided to upgrade my os from 18.04 to 19.10 I use openconnect with the terminal by this command :

sudo openconnect de.cisadd2.com 

Then I enter my username and password and it would always connect but after upgrading my os to 19.10, It has a weird error although it says it is connected.

POST https://de.cisadd2.com/auth
Got CONNECT response: HTTP/1.1 200 CONNECTED
CSTP connected. DPD 90, Keepalive 32400
Connected as 10.10.199.191, using SSL, with DTLS in progress
Established DTLS connection (using GnuTLS). Ciphersuite (DTLS1.2)-(PSK)-(AES-256-GCM).
Error: ipv4: Invalid values in header for route get request.
Error: ipv4: Invalid values in header for route get request.
Error: ipv4: Invalid values in header for route get request.
  • I snipped out the ip usage messages because that just obscures the actual messages, which are that there's invalid values in header(s) for the route requests. – Thomas Ward Nov 1 '19 at 15:05
0

The script /etc/vpnc/vpnc-script uses the now unsupported ip get route $NETWORK/$NETMASKLEN syntax. I fixed that by changing the line 261 to

$IPROUTE route add `$IPROUTE route get "$NETWORK" | fix_ip_get_output | sed -e "s/^$NETWORK\$/$NETWORK\/$NETMASKLEN/"`
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.