1

I reinstalled Ubuntu 18.04.3 LTS on my Acer Switch Alpha 12 yesterday and now i have the problem that it keeps dropping my WiFi Signal after 1-3 minutes when i'm connected to the 5 GHz network (the 2.4GHz network works fine, but since in my case it only delivers a downstream of 10-30k vs. 160k from the 5GHz i'd highly prefer using the 5GHz Signal), the problem is very similar to this thread, but i've already tested all solutions in the comments and this time none of them worked for me, on my last Ubuntu 18.04 LTS installation on the same tablet the proposed solution from desgua did the trick:

This is what stopped my wifi to get unstable, disconnecting all the time, although my wifi is Centrino (not Atheros): disabling IPV6.

Add the following lines to the file /etc/sysctl.conf

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1 

Reboot.

I'm using a Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter with the following configuration (obtained with sudo lshw -class network):

*-network
description: Wireless interface product: QCA6174 802.11ac Wireless Network Adapter vendor: Qualcomm Atheros physical id: 0 bus info: pci@0000:01:00.0 logical name: wlp1s0 version: 32 serial: 94:e9:79:54:69:0d width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=ath10k_pci driverversion=5.0.0-32-generic firmware=WLAN.RM.4.4.1-00079-QCARMSWPZ-1 ip=192.168.0.52 latency=0 link=yes multicast=yes wireless=IEEE 802.11 resources: irq:152 memory:b1400000-b15fffff

It is neither soft nor hard blocken (output of rfkill list all):

0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
1: acer-wireless: Wireless LAN
  Soft blocked: no
  Hard blocked: no
2: acer-bluetooth: Bluetooth
  Soft blocked: no
  Hard blocked: no
3: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no

My router is a Unitymedia Connect Box:

The information below shows current status of this Connect Box.

Standard specification compliant : DOCSIS 3.0 Hardware

version : 5.01 Software

version : CH7465LG-NCIP-6.12.18.25-2p6-NOSH Cable MAC

These are the specs of my 5GHz Signal:

Wireless mode: 802.11a/n/ac mixed

Channel (manual selected): 108

Channel width: 20/40/80 MHz

I've also already tried disabling wifi power management, as proposed by qwr, by setting wifi.powersafe = 2 in /etc/NetworkManager/conf.d/default-wifi-powersafe-on.conf

I've tried turning of IPV6 in the network settings, as mentioned above and as suggestet my dzmanto by additionally deleting line 18 in /etc/dhcp/dhclient.conf:

dhcp6.name-servers, dhcp6.domain-search, dhcp6.fqdn, dhcp6.sntp-servers,

Other solutions i already tried are reinstalling Gnome Network Manager and installing the WICD Network Manager as supposed by Lucas Vasconcellos Czepaniki, which extended the period of working WiFi to 3-7 minutes, but didn't fix the problem and i reverted back to Gnome Network Manager, since removing network-manager-gnome and network-manager also removed my gnome-control-center and with it my settings application and by reinstalling gnome-control-center it automatically reinstalls gnome-network-manager as well.

If anybody can think of a working solution for this i'd be very grateful. I know there are several other threads about this topic, but i've been going through most of them and sadly none of their solutions worked for me.

4
  • I am facing the exact same issue in Ubuntu 20.10. Sad to see there's no answer here yet. @CaptainJack42 - Were you able to fix it? – Anurag Bhandari Mar 6 at 7:21
  • @AnuragBhandari In the end i gave up and didn't manage to fix it, but found out that apperently there was something wrong with the network drivers and ipv6 support in Ubuntu 18.04. Back than i installed Debian 10 on the tablet which worked fine and now recently swapped to ubuntu 20.04 which also works fine now. – CaptainJack42 Mar 7 at 8:52
  • Thanks for the update. I guess I'll tinker with network drivers a bit. – Anurag Bhandari Mar 8 at 9:13
  • I found this thread useful in my case askubuntu.com/questions/1030653/…, particularly answers by desgua and dzmanto. My connection hasn't dropped even once in the 10 mins since I applyed the suggestions! – Anurag Bhandari Mar 14 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.