1

After upgrading from Ubuntu 19.04 to Ubuntu 19.10, my VPN connection doesn't work anymore.

My settings:

phase1: 3des-sha1;modp1024
phase2: 3des-sha1

This worked fine so far.
I checked the packages installed:

network-manager-l2tp 1.2.10-1; 
network-manager-l2tp-gnome 1.2.10-1; 
xl2tpd 1.3.12-1.1
libreswan 3.29-2

What can I do?

  • Without log output from sudo journalctl -b, it is hard to say what is going wrong. network-manager-l2tp 1.2.16-1 fixes some issues and may fix the issue you are having, but hard to say without knowing what the error messages say.. – Douglas Kosovic Nov 8 '19 at 6:15
  • state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed') – user757306 Dec 17 '19 at 9:49
0

Try the network-manager-l2tp 1.2.16-1 backport from the following PPA:

With network-manager-l2tp 1.2.16-1, you should be able to delete the phase 1 & 2 algorithm entries as it now uses a merge of proposals from Win10 and iOS instead of using the libreswan or strongswan default set of proposals.

  • state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed') output of journal – user757306 Dec 17 '19 at 9:46
0

I had the exact same problem upgrading from 19.04 to 19.10. I tried the NetworkManager upgrade too, but that didn't solve my problem. I then did the following three things, and now everything works again:

  1. Replaced libreSwan with StrongSwan (I found if I purged libreSwan, StrongSwan was automatically installed)
  2. Explicitly specified the Phase 1 and Phase 2 algorithms: "3des-sha1-modp1024" and "3des-sha1" respectively.
  3. Ensured only MSCHAPv2 was checked under PPP Settings.

I have a feeling #3 is what solved my problem as I did notice a few more authentication boxes were checked under PPP Settings after the upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.