10

I had Ubuntu 19.04 64 bit virtual machine I upgraded it to 19.10. After the upgrade finished the virtual machine has stuck on boot in VMware workstation 15. I had used a vmdk image for 19.04 available here www dot osboxes dot org slash Ubuntu (less than 10 reputation can not post more than 8 links so have to keep it that way)

I made a couple of videos while I was upgrading the virtual machine ( I followed the instructions here www dot liquidweb dot com/kb/troubleshooting-please-install-available-updates-release-upgrading/) The videos are as follows

Ubuntu 19.04 to 19.10 upgrade messages

Part 1: https://youtu.be/la-kwFYGl14
Part 2: https://youtu.be/U_j-aQRMGW4
Part 3: https://youtu.be/80OPkahASmQ
Part 4: https://youtu.be/nPSo-7daCuQ

Now what could be the problem here as why a fresh upgrade is not able to boot into a system. What should I check in here or do to fix this? This is a fresh upgrade and what ever kept happening I let it happen. I logged in to tty6 I get following screenshot. tty6 screenshot I have not restarted the system since the upgrade from 19.04 to 19.10 kept happening.

Then while I posted this question here I some how was able to restart the system and now I get

end kernel panic not syncing :VFS: Unable to mount root fs on unknown block (0,0)

kernel panic unable to mount root on unknown block 0,0 Here is a video for the same. Now I don't know what should I do. Why this problem came. How to debug this and fix this. Rather than creating a new VM by downloading a new ISO I am more interested to learn and fix the problem which has caused this.

Part 5: https://youtu.be/JhFJEj2dUOM
I seem to have figured out something which might be applicable as mentioned at Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) the thing is before upgrading I did not note down on a paper or pencil as which kernel version was running or to what version the upgrade took place. I have been running defaults only so it should not be a problem. Someone in comments mentioned

"On my ubuntu 19.10 I've had to run apt install initramfs-tools in order to get update-initramfs command –" How can I execute these commands given my situation in video 5.

The thing is I do not know how to work with advanced boot menu please see the screenshots and videos I uploaded to understand my situation.
advance boot options
which kernel to boot in advance options

Even after booting into one of the kernels in advanced options, I get kernel panic messages.

There is some knowledge gap in my situation I probably have figured out something which I should try but I am not able to understand how to proceed from here.

12

After a long struggle I have been able to fix this with the help of previous answers and trial and errors. I booted into Advanced mode while booting Ubuntu press F2 when you see grub2 bootloader. On some systems you may need to press Shift to get to advanced boot menu.

In my case since I was in a VMware Workstation environment I pressed Shift or F2 to get to boot menu as shown below

which kernel to boot

So now you see many kernels are shown I started selecting one by one.One kernel after other and tried booting in some cases I failed and I got the same error message saying kernel panic vfs unable to mount root filesystem could not find (0,0)

The kernel that worked in my case from above entries was

5.0.0-32-generic

The one highlighted in screenshot. I booted it and after I could boot rather than going to GUI or GDM login which will not work. Switch to a text-based virtual console by pressing (if you are in a virtual machine you may need to press function key on real hardware to get to text based console pressing Fn key is not required) Ctrl+Alt+Function+F2 or
Ctrl+Alt+Function+F3 upto F12 meaning any of these key combination will give you a tty
Ctrl+Alt+Function+F4
Ctrl+Alt+Function+F5
Ctrl+Alt+Function+F6
Ctrl+Alt+Function+F7
Ctrl+Alt+Function+F8
Ctrl+Alt+Function+F9
Ctrl+Alt+Function+F10
Ctrl+Alt+Function+F11
Ctrl+Alt+Function+F12

Which ever key it gives you a terminal without a GUI press just one of the combinations. (Just be cautious that in some systems Wi-Fi might get disabled with some function key so leave that combination of function key) If you are on a real hardware you need to press Ctrl+Alt+ (F1/F2/F3/../../../F10/) (or whichever key works for you, although usually all will work). The GUI though you will get in either Ctrl+Alt+Fn+F1 or Ctrl+Alt+Fn+F5/F6 depending upon which tty is set for default GUI in your case. Since I am on VMware so I had to press Fn key also other wise you don't need to press Fn just a combination of Ctrl+Alt+F1/F2/F3/F4/F5/F6/F7/F8/F9/F10/F11/F12
key will give you required command prompt login. Then login with your username and password. I was logged into tty6 (Ctrl+Alt+Fn+F6)

logged in to tty6

As explained on answer here:

update-initramfs -u -k 5.3.0-19-generic (or your version)

If you don't know your version. Use:

dpkg --list | grep linux-image

And just update Grub:

update-grub2 

But just this grub update won't work as grub still is not there on hard disk. I am uploading screenshots in my case this command failed also at one or two kernels

generating initramfs

dpkg --list | grep linux-image:
dpkg --list | grep linux-image

Now without logging in GUI and before a reboot (after doing update-grub2) I did a

dpkg --configure -a 

I got following screenshot during grub upgrade

grub update and re install message

As mentioned in this answer https://askubuntu.com/a/939883/992730 press space to select the desired entry and arrow keys to move up and down. Now you see even after a update-grub2 command dpkg --configure -a was required.

Now all the broken dependencies or packages which were being upgraded previously and some how had failed in between due to some error restarted from a point where they should have been continuing.

Then after a reboot I was able to get back a working system 19.10

finally working 19.10

Here I was finally successful.

| improve this answer | |
  • Thanks for this! I had the same exact problem. although, I never got the seconds last screen (device selection). – pythonator Dec 6 '19 at 19:38
0

Thx very much for your infos and fix! I ran into the same issue. For me it also helped to logout from the window manager before the upgrade and go to the console (for example tty6). Here I started the upgrade process in the command line. After a reboot all worked perfectly.

| improve this answer | |
  • Please edit your answer by explaining step by step how you managed to solve that issue (add command line for example) – damadam Nov 12 '19 at 10:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.