0

I'm running 19.10 (although this was also an issue on 18.04 before I upgraded) on an older Intel NUC. I am unable to see or access the wired settings for my connection (see attached image), nor is the OS able to access the internet for updates. For example, the Ubuntu Software app, when I go to Updates, it says I need to go online to check for updates. I have no problem actually getting online with a browser or whatever...I'm posting this from this machine...but updates in that app, as well as things like the Online Account settings, don't think I'm online.

Let me know if there's any other info you need to help me diagnose this problem. Thanks in advance for any help.

Network Settings

EDIT (further clarification) - the system software updater works fine, but the "app store style" software updater tells me to "Go online to check for updates".

Also, when I go to to the "power menu" and see the options for my user account, night light mode, and the network stuff, it says "Wired Unmanaged", but if I click on "Connect" under that, it doesn't do anything.

I'm also running a handful of docker images, just fyi, because I know that has it's own networking "situation" going on.

EDIT (more info) - running desktop version

$ cat /etc/network/interfaces
# ifupdown has been replaced by netplan(5) on this system.  See
# /etc/netplan for current configuration.
# To re-enable ifupdown on this system, you can run:
#    sudo apt install ifupdown
$ cat /etc/netplan/*.yaml
# This file is generated from information provided by
# the datasource.  Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
    ethernets:
        eno1:
            dhcp4: true
    version: 2
4
  • Is this a Desktop or Server installation? Edit your question and show me cat /etc/network/interfaces and cat /etc/netplan/*.yaml. Start comments to me with @heynnema or I may miss them.
    – heynnema
    Nov 1 '19 at 15:49
  • @heynnema desktop version. Results of the commands are now shown in the edited original question. Thanks. Nov 1 '19 at 17:20
  • 1
    You need to change your network configuration to tell it to use Network Manager. Like at netplan.io/examples#using-network-manager-as-a-renderer. Then reboot.
    – Thomas Ward
    Nov 1 '19 at 17:28
  • That worked, thank you. For reference, I added a line that said "renderer: NetworkManager" to the /etc/netplan/*.yaml file and rebooted. It appears that all the stated issues are now working correctly. Nov 1 '19 at 18:22
0

From the comments...

Change your /etc/netplan/*.yaml file to look like this...

network:
  version: 2
  renderer: NetworkManager

sudo netplan --debug generate

sudo netplan apply

reboot

Then use the standard NetworkManager GUI to configure your network.

1
  • Instead of reboot for me it also was sufficient to simply sudo service network-manager restart.
    – tschwinge
    Aug 23 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.