1

I am trying to get QEMU/KVM to run on ubuntu 19.10 but when starting the virtual machine (Windows 10) it freezes the complete system (guest and host). I was suspecting that this is because the linux-kvm package was not installed. I installed the package and the dedicated kernel linux-image-5.3.0-1004-kvm.

When trying to boot this kernel I get

error: /boot/vmlinuz-5.3.0-1004-kvm has invalid signature

Assuming the kernel not to be signed, I tried to sign it using this tutorial. Result:

sbsign --key MOK.priv --cert MOK.pem /boot/vmlinuz-5.3.0-1004-kvm Invalid DOS header magic

Pretty confused I tried one last thing and turned off secure boot. It would still give me the invalid signature after reboot.

Any further input what I could do?

2

Please take a look at this bug report. It sounds like you're having a similar issue that several other people (including myself) are having since upgrading to 19.10.

They're trying to get to the bottom of the problem, but they need people to post log files, etc.

In addition, the kernel modules should be installed automatically as dependencies for qemu-kvm.

This will install everything you need:

sudo apt install -y qemu-kvm libvirt-daemon-system libvirt-clients bridge-utils virt-manager

So I don't think the problem is caused by not having the correct kernel modules / kernel installed.

1
  • yes indeed, I changed the network adapter and the system does not freeze anymore. From the bug report you linked I see that the issue is still unsolved today when using an e1000e adapter
    – sebicm
    Nov 14 '19 at 10:18
1

There seems to be a bug in the default e1000e virtual NIC driver which can freeze your host system whenever a Windows VM tries to connect to the Internet.

My workaround for this is to edit the Windows VM configuration, changing the VM's NIC device model from e1000e to virtio, applying the changes and booting the Windows VM.

Screenshot here

Update: It's been running solid for about 10 hours with heavy load and no more freezes.

1
  • Thanks for sharing the solution. Changing the network adapter to the virtio adapter did the trick!
    – sebicm
    Nov 14 '19 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.