0

My Notebook

 sudo dmidecode -t1
# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x000E, DMI type 1, 27 bytes
System Information
        Manufacturer: LENOVO
        Product Name: 2350B58
        Version: ThinkPad T430
        Serial Number: PBVVBLH
        UUID: cdcb8a01-5190-11cb-9490-98976e1f3194
        Wake-up Type: Power Switch
        SKU Number: LENOVO_MT_2350
        Family: ThinkPad T430

tlp is not on my system. Im running Lubuntu

Okt 31 13:52:30 Guilmon thermald[743]: error: could not parse file /etc/thermald/thermal-conf.xml

I was searching around and found thermald configuration file for Thinkpad T430

After restart of thermald.service, I get following error.

thermald[6496]: sysfs write failed /sys/devices/virtual/powercap/intel-rapl/intel-rapl:0/enabled

fine

ls -al /sys/devices/virtual/powercap/intel-rapl/enabled 
-rw-r--r-- 1 root root 4096 Okt 31 19:30 /sys/devices/virtual/powercap/intel-rapl/enabled

The problem is, I have to stop thermald before I poweroff the system.

 dpkg -l| grep sensor
ii  iio-sensor-proxy                              2.5-0ubuntu1                        amd64        IIO sensors to D-Bus proxy
ii  libqt5sensors5:amd64                          5.12.2-1                            amd64        Qt Sensors module
ii  libsensors-config                             1:3.5.0-3ubuntu1                    all          lm-sensors configuration files
ii  libsensors5:amd64                             1:3.5.0-3ubuntu1                    amd64        library to read temperature/voltage/fan sensors
0

Can't have tabs in the .xml file. <ThermalSensor> has two tabs in front of it. Use the following corrected /etc/thermald/thermal-conf.xml file...

<?xml version="1.0"?>
<ThermalConfiguration>
<Platform>
        <Name>T430</Name>
        <ProductName>*</ProductName>
        <Preference>QUIET</Preference>
        <ThermalSensors>
                <ThermalSensor>
                        <Type>pkg-temp-0</Type>
                        <Path>/sys/class/thermal/thermal_zone0/temp</Path>
                        <AsyncCapable>1</AsyncCapable>
                </ThermalSensor>
        </ThermalSensors>
        <ThermalZones>
                <ThermalZone>
                        <Type>cpu package</Type>
                        <TripPoints>
                                <TripPoint>
                                        <SensorType>pkg-temp-0</SensorType>
                                        <Temperature>90000</Temperature>
                                        <type>max</type>
                                        <ControlType>PARALLEL</ControlType>
                                        <CoolingDevice>
                                                <index>1</index>
                                                <type>rapl_controller</type>
                                                <influence> 50 </influence>
                                                <SamplingPeriod> 10 </SamplingPeriod>
                                        </CoolingDevice>
                                        <CoolingDevice>
                                                <index>2</index>
                                                <type>intel_pstate</type>
                                                <influence> 40 </influence>
                                                <SamplingPeriod> 10 </SamplingPeriod>
                                        </CoolingDevice>
                                        <CoolingDevice>
                                                <index>3</index>
                                                <type>intel_powerclamp</type>
                                                <influence> 30 </influence>
                                                <SamplingPeriod> 10 </SamplingPeriod>
                                        </CoolingDevice>
                                        <CoolingDevice>
                                                <index>4</index>
                                                <type>cpufreq</type>
                                                <influence> 20 </influence>
                                                <SamplingPeriod> 10 </SamplingPeriod>
                                        </CoolingDevice>
                                        <CoolingDevice>
                                                <index>5</index>
                                                <type>Processor</type>
                                                <influence> 10 </influence>
                                                <SamplingPeriod> 10 </SamplingPeriod>
                                        </CoolingDevice>
                                </TripPoint>
                        </TripPoints>
                </ThermalZone>
        </ThermalZones>
</Platform>
</ThermalConfiguration>
  • Zhanks @heuynnema I draw thermald from git. – nobody Nov 3 at 11:01
  • @nobody I know that you got the .xml file from git. Did you try my .xml file? – heynnema Nov 3 at 12:30
  • sorry @heuynnema I had to make a new install. and make it short and painless sudo apt purge thermald – nobody Nov 4 at 18:01
  • @nobody did you end up reinstalling thermald, or just give up? Did you try my .xml file first? – heynnema Nov 4 at 18:03
  • @heymenna, I have do reinstall the whole os, because I format it instead of bionic. :( – nobody Nov 4 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.