0

I have multiple issues with windows 10 guest after upgrading to 19.10. I read that I need to set the kernel_irqchip=on

I did the following in the machine xml file.

...
  <qemu:commandline>
    <qemu:arg value='-machine'/>
    <qemu:arg value='accel=kvm'/>
    <qemu:arg value='kernel_irqchip=on' />
  </qemu:commandline>
</domain>

I get the following error when I start the machine.

File "/usr/lib/python3/dist-packages/libvirt.py", line 1080, in create if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self) libvirt.libvirtError: internal error: process exited while connecting to monitor: 2019-10-31T18:26:36.904432Z qemu-system-x86_64: kernel_irqchip=on: Could not open 'kernel_irqchip=on': No such file or directory

What is the appropriate way of setting that flag on using libvirt (not the qemu command line)

0

You don't have to (in fact you shouldn't) force that in via qemu-commandline (and if you do it is kernel-irqchip instead of kernel_irqchip).

This is controlled via the ioapic feature. You should use the feature that is like:

 <features>
   <ioapic driver='kvm'/>
 </features>

Hereby driver kvm maps to "kernel_irqchip=on" and driver qemu maps to "kernel_irqchip=split".

Also could you check if your issue might be the same as this bug and if so chime in there. Especially if kernel-irqchip really helps state so

|improve this answer|||||
  • I would like to add that my freezing issues with windows 10 is only when I use OVMF bios and it temporary resolves if I restart libvirtd prior to booting the win10 guest. Also the freezing issues seems to be related to an IRQ. After 5 minutes of freezing with high CPU load my system is back to normal. – user63726 Nov 1 '19 at 15:19
  • I read somewhere that I also need to have this in features <ioapic driver='kvm'/>. This change did not fix my issues. – user63726 Nov 1 '19 at 15:23
  • I have add the <irqchip mode='on'/>. I get this error: libvirt.libvirtError: unsupported configuration: unexpected feature 'irqchip'. Is this a bug in the implementation of libvirt in 19.10 – user63726 Nov 1 '19 at 15:28
  • Sorry @user63726 , this was based on a former version but eventually got accepted as this version. you need ioapic modes to define it like here. Updating my comment above ... – Christian Ehrhardt Nov 6 '19 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.