2

I can't set the shortcut to change keyboard layouts from within the Keyboard and Mouse program on Lubuntu, because it seems that fcitx overrides it and resets it everytime.

I followed the Lubuntu manual for Keyboard and Mouse, i.e. selected Keys to change layout → changed it → pressed Apply → restarted, but it remains empty.

When I try to use fcitx instead of default Lubuntu keyboard config, it results in strange keyboard layout behaviour (I made custom changes to /usr/share/X11/xkb/keycodes and /usr/share/X11/xkb/symbols, so my Ctrl will be Alt, so I can have a MacOS-like layout), so fcitx is a no way for my configuration.

How can I allow Keyboard and Mouse software to work normally? Or maybe there is some kind of file where this software writes, where I can write shortcut manually via vim?

  • A suggestion by @N0um3n0 on IRC is to "Configure the Russian and English languages ​​from the keyboard layout in the configuration of lxqt. subsequently add the kbindicator applet to the panel, which lets us select between one language or another. In principle, it seems to work" – guiverc Nov 2 at 21:07
  • Also, to be clear, are you referring to "Shortcut Keys" (lxqt-config-globalkeyshortcuts) or "Keyboard and Mouse" (lxqt-config-input)? In other words, are you trying to add/change a global key shortcut (e.g. to launch the browser) or trying to change the shortcut that allows switching keyboard layouts? Also, how are the keycodes/symbols files defined? Are the defaults restored? – wxl Nov 2 at 21:52
  • @guiverc kbindicator is the one applet I'm using now. Everytime I need to change language I just press it with my cursor. The problem is I'm trying to configure that I can change language input for keyboard via keys shortcut, which is not possible, because when I try to change setting (specify which shortcut to use) in Keyboard and mouse settings, it's being cleared and is not applied to the system. I tried starting Keyboard and mouse settings with sudo via terminal - no luck either. – idchlife Nov 3 at 18:13
  • @wxl I'm referring to lxqt-config-input (Keyboard and mouse). If I knew terminal command to switch keys, I suppose I could add it to Global Key Shortcuts, but every command I stumbled upon on stack and forums is to manually change to some language and it's for ubuntu/lubuntu with lxde, which does not work for some reason in my system. I can't quiet figure out why I have 2 ways to control my keyboard layouts in clean installed Lubuntu with LXQT: fcitx and lxqt-config-input. And one conflicts with another. And both work poorly (fcitx poorlier) – idchlife Nov 3 at 18:17
  • 1
    I've been considering giving this suggestion since you first posted (same hour actually, and the prior one). I would in your case have tried the Lubuntu site discourse.lubuntu.me ; as you may have got more responses from Lubuntu devs. Your posts have created some [irc] discussion & work that will occur for 20.04, but I'm not capable of fully understanding or relaying it here (I only use english & have little understanding of the stack sorry) – guiverc Nov 5 at 7:56
0

Solution posted here: https://discourse.lubuntu.me/t/lubuntu-19-10-lxqt-cannot-change-keyboard-layout-shortcuts-not-working/507/1

In the end there is workaround for the problem. Just add layout (any), choose shortcut, press apply. Shortcut will be saved and working. Then remove additional not needed layout and press apply. You now have 2 layouts and working shortcut!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.