1

I have an Intel Compute Stick STCK1A32WFC and I want to convert it into some sort of media streaming device. I am trying to install Ubuntu (or any kind of GUI linux) but every time, it will either not get to the GUI part or crash after I hit confirm on the installer. The linuxium-atom ISOs are a result of this tool. The ubuntu kernel doesn't come pre-installed with the right wifi, bluetooth and audio drivers so the respin adds them in for you. I read somewhere that this is no longer an issue as 19.04 fixed this... even though the results say otherwise.

I know it is not:

  • My USB since I have used it before with success
  • The ISOs since I have checked the md5s multiple times
  • The compute stick has the capability for 64 bit
  • Secure boot

I have tried:

  • Updating BIOS (success)
  • ubuntu-14.04.6-desktop-amd64.iso (will not get past splash screen)
  • ubuntu-14.04.6-server-amd64 (will completely finish installer, success BUT no wifi, bluetooth or sound and can't get internet access, tethering doesn't work)
  • lubuntu-19.04-desktop-amd64 (will not get past splash screen)
    • Tried nomodeset and acpi=off as grub args but one results in a purple screen and the other stops and displays an error (initramfs) Unable to find a medium containing a live file system
  • ubuntu-16.04.6-desktop-amd64 (will not get past splash screen)
  • linuxium-atom-ubuntu-16.04.6-desktop-amd64 (will not even show splash screen)
  • linuxium-atom-lubuntu-19.04-desktop-amd64 (Gets past splash screen and I can access desktop GUI)
  • linuxium-atom-v5.4-rc5-xubuntu-18.04.3-desktop-amd64 (Same as the one before, gets into GUI but also crashes on installation)

On linuxium-atom-lubuntu-19.04-desktop-amd64, I can start the installer, select language, region, keyboard, username and password. Every time the computer turns off when I hit the confirm button. From what I can read in the milliseconds that it starts the installation process, it might be trying to mount something. Also, Lubuntu will seem to crash randomly, like once tried CTRL + ALT + T and it crashed, another time closing the terminal crashed it and another time both worked fine.

I have tried to look for logs on the USB pendrive after the compute stick powers off but can't seem to find them. Have tried looking online but only find results for installed OSes.

Note: When I say it wont get past x point, I mean the compute stick powers off.

Spend over a day on this, help would be much appreciated!

  • You have tagged 14.04, Ubuntu 14.04 LTS is EOL & thus off-topic, Ubuntu 14.04 ESM is supported only by Canonical through Ubuntu Advantage and off-topic on this site (askubuntu.com/help/on-topic). Lubuntu 16.04 LTS is a flavor of Ubuntu, as such had 3 years of supported life so only Ubuntu 16.04 LTS (desktop with Unity, server with no desktop, or Kylin is fully supported). You've mentioned on-topic releases too, but tagged and mentioned EOL & off-topic releases. – guiverc Oct 30 at 10:33
  • @MegaVolt intel.com/content/www/us/en/support/articles/000005899/mini-pcs/… states Intel provides no support for Ubuntu and their list of Customer Reported OS only shows linuxiumcomau.blogspot.com/2016/05/… for a successful install; mentioning other OS is not constructive. – K7AAY Oct 30 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.