I'm running Ubuntu as my guest OS from vmware and want to add a new HDD. so I added this

enter image description here

The 10 GB HDD added but I do not see it appearing in Ubuntu anywhere. I tried sudo ls /dev/sd* and all I got was sda0 and sda1.

I tried GParted but it won't run. I tried KDE Partition manager but it errors out saying you are not the root. I tried Ubuntu's built-in disk manager and this is what it shows:

ubuntu disk tool

and here is the output of lsblk: lsblk output

So what should I do? How do I get the new HDD in linux?

  • Possible duplicate of How to make partitions mount at startup? – 24601 Oct 30 '19 at 7:26
  • @Graham no it's not. that question talks about mounting it at a location, mine is not even showing anywhere as if it does not even exist – Simple Fellow Oct 30 '19 at 7:29
  • 1
    Does it show when you list block devices (lsblk)? (I'd then likely use blkid to get the detail to add the entry in the file-system table). If it doesn't show I'd likely blame a vmware config issue on host. – guiverc Oct 30 '19 at 8:06
  • @guiverc just added the lsblk output to the question. – Simple Fellow Oct 31 '19 at 9:56

it turned out to be a pretty stupid thing. I read the documentation and did a little research. it seems that I needed a drive size at least 20 GB.

not sure if that's some limitation from ubuntu or VMware. so I did that and it appeared fine as /dev/sdb and everything is working fine now.

10GB drive just doesn't work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.