1

Whenever I run a terminal (which is always) it gets full of many, many nm-applet messages like this:

(nm-applet:3693): Gtk-WARNING **: 18:04:36.418: Can't set a parent on widget which has a parent

(nm-applet:3693): Gtk-CRITICAL **: 18:04:36.424: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

I would have thought these types of messages would be redirected to .xsession-errors but for some reason that file is 0 length. The file permissions are 644 so I don't think that's the issue.
I don't know what's controlling the nm-applet startup. (If I knew that I could redirect errors to .xsession-errors or /dev/null, but.)
Anyone know how to fix this? It is extremely intrusive and annoying.
TIA

  • Are you getting this output whenever you launch a terminal, or after you have input commands? If so, what commands? nm-applet is the GNOME front-end for NetworkManager and the error suggests that there is a problem with a widget - if you have some kind of network widget in use, try disabling or uninstalling it. – Nmath Oct 29 '19 at 23:49
  • The errors come up as soon as I launch the terminal, before I've even typed anything in. I don't have any network widget installed, just what came with NetworkManager. – Stuart Oct 30 '19 at 17:50
  • 1
    OK, I found the solution to the problem. I found a line in ~/.bashrc left over from a previous installation of a different distribution: dbus-launch nm-applet & Removing this fixed it. – Stuart Oct 30 '19 at 20:13
  • please add this as an answer, so it will be available for others who may visit the site with the same issue – Nmath Oct 31 '19 at 2:07
1

Here's the answer: I had installed Ubuntu on a machine on which I had been running a different distribution (Gentoo) with no systemd or other Ubuntu init stuff. When I installed Ubuntu, I kept the /home partition from before. In the .bashrc file in $HOME, was a line

dbus-launch nm-applet &

That was the cause of all my problems. I got rid of it and everything is fine now.

|improve this answer|||||
0

Yeah, this is a known bug. Please add your "This affects me to" to give it higher priority.

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1751673

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.