0

How can I get myself out of this boot loop?

I am a bit at a loss, my Grub screen is empty (shows no options to choose from.) I now only have access to Grub options if I hold down the Shift key during the time Grub is being processed.

I got myself into this pickle while upgrading Ubuntu 19.04 to 19.10, and something went wrong.

I started going through the different Kernel options to see if one would get the system back up. The last one did. I was able to get to a login window; however, logging into Ubuntu would not work. So I tried logging in using the Unity Desktop option. This brought me to the Unlock Login Keyring. But the Unity Desktop UI is empty -- besides a auto-start opening Rhythmbox. Somehow in Unity or Ubuntu-MATE. I can't get a Terminal doing Ctrl+Alt+T.

As suggested, using Ctrl+Alt+F5 works, but I can't figure out what is missing in order to boot into Ubuntu Desktop 19.10, tty5 login states:

Welcome to Ubuntu 19.10 (GNU/Linux 5.3.0-19-generic x86_64)

I tried login into unity --:1 to get into a standard UI based on this helpful post but got this:

compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : false
compizconfig - Info: Profile     : mate
Switched to profile 'unity-lowgfx' (for enfironment 'mate')
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : false
compizconfig - Info: Profile     : unity-lowgfx
WARNING: no DISPLAY varable set, setting it to :0
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Info: Loading plugin: :1
compiz (core) - Error: Failed to load plugin: :1

It looks like it is somehow switching to mate and fails loading the plugin.

Doing a reboot brings me straight back into some leftover Ubuntu-MATE; without UI -- not very helpful.

  • This is similar problem, and for me disabling auto login worked: askubuntu.com/questions/1181649/… – MeSo2 Oct 31 '19 at 19:15
  • 1
    Please post your comment as an answer. – WinEunuuchs2Unix Oct 31 '19 at 21:50
  • This is similar problem, and for me disabling auto login worked: askubuntu.com/questions/1181649/… – MeSo2 Nov 1 '19 at 0:59
  • 1
    @WinEunuuchs2Unix I just tried again, but somehow I can't... It must be a web UI bug – MeSo2 Nov 1 '19 at 0:59
  • Thanks your answer was posted. I hope you don't mind but I improved it to traditional standards. – WinEunuuchs2Unix Nov 1 '19 at 1:22
2

I solved my own question with this answer:

I had to disable "Auto Login" and then the screens were normal again.

To summarize the link:

sudo -H gedit /etc/gdm/custom.conf

and commented out these lines (by placing a # in front):

AutomaticLoginEnable=True
AutomaticLogin=username
| improve this answer | |
  • @WinEunuuchs2Unix thank you for the edit, I just added this askubuntu.com/questions/1185377/… new post related to the problem I found. Not sure if it is a bug... – MeSo2 Nov 1 '19 at 1:28
  • I voted to close your new question as a duplicate of an older question – WinEunuuchs2Unix Nov 1 '19 at 1:39
0

You can get into a terminal. You just use the following combination: CTRL + ALT + F5 You'll get a tty window, where no desktop is needet. Just like a serverinstance of Ubuntu. Then you log in there and have full access as your user, just without the GUI. To Switch back to the gui: Reboot or CTRL + ALT + F1 (Source: What is a tty, and how do I access a tty? )

And yes, you probably have to perform an update-grub if you change anything to the boot params. To get it back, I would suggest that you use the following commands(this may fix the failure in the upgrade):

sudo -i 
apt update && apt dist-upgrade -y
dpkg --configure -a
apt-get dist-upgrade
apt-get autoremove
apt-get autoclean
update-grub
reboot
| improve this answer | |
  • CTRL + ALT + F5 worked. I ran your suggested commands, but that somehow brought me back into Uinity. update-grub fines different images, but the Grub UI is still empty after a reboot bringing me back into that boot loop. – MeSo2 Oct 29 '19 at 19:51
0

What's your filesystem?

This sounds similar to what I initially experienced while trying out 20.04's ZFS root installer (which I've read is in 19.10, bit I could never find it). After logging in from the GUI I'd be kicked right back out.

If by any chance that's your issue, the reason is Ubuntu-specific. You need to rename the datasets. See here.

Another time this happened to me I had something in my ~/.profile that was throwing an error.

Long story short, your issue could be caused by anything without more info.

| improve this answer | |
  • fs is ext4 root in LVM2_member (I am now thinking of a auto-loader code fix some time back, that needed to be added to get X to do something ... but do not remember. Could this be causing it?) – MeSo2 Oct 31 '19 at 2:21
  • .profile content: if [ -n "$BASH_VERSION" ]; then if [ -f "$HOME/.bashrc" ]; then . "$HOME/.bashrc" fi fi if [ -d "$HOME/bin" ] ; then PATH="$HOME/bin:$PATH" fi – MeSo2 Oct 31 '19 at 18:18
  • where is rpool/USERDATA in root? – MeSo2 Oct 31 '19 at 18:48
  • My comment only matters if your filesystem is ZFS, which it isn't (it's ext4 on LVM). Also your .profile looks fine, so I don't know what the issue is. – dcmorse Oct 31 '19 at 20:06
  • thanks for following up. I found that the autologin was causing the problem (see comment) "Answer Your Question" sent me there. Not sure why – MeSo2 Oct 31 '19 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.