0

My installation went from Gnome to Lubuntu via installation of lubuntu-desktop and subsequent removal of the gnome packages, so it is a bit nonstandard.

Somewhere in between, the emoji support for the console broke, and I would like to know how to fix it (installation is otherwise fine). The existing answers on AskUbuntu don't apply or don't solve the issue.

The issue: When I execute curl v2.wttr.in/Berlin in the terminal, I expect to see an extensive weather report with proper symbols (rain clouds etc), but on this computer, most of them are just the 'tofu' boxes indicating that a symbol wasn't found.

This is how it is supposed to look like: enter image description here

And this is how it really looks like: enter image description here

Notice the difference with the symbols for 'rain' and 'partly cloudy'. How can I get the full emoji range back?

fonts-noto-color-emoji is installed, I also ran fc-cache -f -v.

  • Have you tried gnome-terminal? (just to localize the problem) – Igor Chubin Oct 30 at 15:46
  • I tried on several terminals, Konsole, qterminal, and also xterm as the standard one. They all show the same behaviour. – emk2203 Nov 4 at 8:32
  • I suppose that your cairo library is too old – Igor Chubin Nov 5 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.