7

I have recently installed Ubuntu 19.10 on my laptop. I installed Google Chrome because I use a few Chrome apps that I want to run in Ubuntu. I created shortcuts on the desktop but they just appear as .desktop files, and when I double-click them the files just open in text editor. I have tried making sure the files are set to executable but it still isn't working. How do I set it so I can run these shortcuts?

As an example of what one of these files contains, here's the contents of the "Word Online" desktop file, which is actually called chrome-fiombgjlkfpdpkbhfioofeeinbehmajg-Default.desktop

#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Terminal=false
Type=Application
Name=Word Online
Exec=/opt/google/chrome/google-chrome --profile-directory=Default --app-id=fiombgjlkfpdpkbhfioofeeinbehmajg
Icon=chrome-fiombgjlkfpdpkbhfioofeeinbehmajg-Default
StartupWMClass=crx_fiombgjlkfpdpkbhfioofeeinbehmajg

Contents of this file are exactly the same as the equivalent .desktop file on my Desktop PC. This file works, but I have an earlier version of ubuntu on my Desktop (18.04 LTS) so I'm guessing it's an issue with 19.10....

  • What are the contents of said .desktop files? – schrodigerscatcuriosity Oct 28 '19 at 21:59
  • I've had the same problem with Chromium. I can't try Chrome as it's impossible to set up (does anybody know a good guide?). I tried out Fossa till I had to go back to 19.10 and it had a feature for Chrome that actually ran the shortcuts like programs...but only with Chrome. Hopefully they keep it in the final release. I actually asked about it but with no luck: askubuntu.com/questions/1208900/… – Barra Feb 9 at 20:18
5

I believe all you have to do is right click on the .desktop file on the Desktop, and click Allow Launching.

enter image description here

which will show the application's icon and make it launchable.

enter image description here

| improve this answer | |
  • 8
    I don't see an "Allow Launching" option.... – SamuelH Oct 29 '19 at 9:49
  • @SamuelH you can see this option IF the .desktop file is on the Desktop (ie, copied in the desktop folder) – cmak.fr Oct 30 '19 at 10:53
  • 2
    @cmak.fr - the files ARE copied into the desktop folder. – SamuelH Oct 31 '19 at 14:27
  • For some reason I have to right-click and then click "Allow Launching" every time I log in. Is anyone else having this problem? I'm on 20.04. – joe Nov 13 at 20:03
3

For now I have switched back to 18.04. Hopefully by the next LTS release this is something that will have been worked out.

| improve this answer | |
1

Allow Launching option doesn't show if file already has execution permission set before you upgraded to new version. To resolve:

chmod 644 file_name.desktop

then right click on the file in the desktop, you will see allow launching.

| improve this answer | |
  • But I hadn't upgraded. It was a clean install of 19.10. – SamuelH May 12 at 10:14
  • Have you tried above solution even though? – Ghazi May 13 at 17:41
1

To get the Allow Launching option in the contextual menu you need to change the permissions to -rwxr-xr-x

you can do:

chmod 755 <you file>.desktop
| improve this answer | |
1

since 19.10 there were some changes in GNOME.

from now on you have to put your .desktop files in spacial locations to execute them.

if you have a local installation or a script that should be executed place the .desktop file in:

~/.local/share/applications$ 

if the app should be executable for every user you have to use the root dir.

/usr/share/applications

to copy things the you have to be root or use sudo. for example:

sudo cp MyApp.desktop /usr/share/applications

next thing is important as well. If one of the paths in the .desktop file is wrong your app will not appear in the app browser.

it is remanded to use "" for the path. because if the is a space or a spacial symbol in the path this could cause problems. You can NOT use ~/ in desktop files! So always use the whole path to your icon and executable.

Example:

[Desktop Entry]
Type=Application
Name=MyApp
Comment=open source CAD program
Exec="/home/USER/path to your app/MyApp.AppImage"
Icon=/home/USER/path_to_your_icons/ICON.png
Terminal=False

hope this will help.

| improve this answer | |
  • Does not work, Ubuntu 20.04. – Danijel Nov 17 at 11:01
0

I also had an issue with this in 19.10, but I wasn't willing to downgrade since I installed to ZFS rpool (highly recommended).

I tried to create .desktop files for web links manually, and also could not see the "allow launching" option when right-clicking on them. This might be different for application launchers, but for manually created web links, it does not appear.

So here's how I figured out how to do it:

  • In Chrome, open up the web page

  • Go to the 3-dots menu in the top right and select "more tools --> Create Shortcut"

  • Name the shortcut (displayed in Window/Tab) and select whether you want the shortcut to open a new window or in another tab in Chrome (default)

  • Link name defaults a unique identifier, not the name you just gave the shortcut - but don't worry about that

  • Lastly, HERE's where you right-click on the desktop shortcut and select "Allow Launching", and in my case it renamed the shortcut with the name I had just given it and also changes to the Chrome icon

It's actually really easy once you know what to do, and appears to work flawlessly.

Note - the actual files themselves still reflect the UUID given to them by chrome during the creation process. Example:

Desktop in terminal revealing UUIDs for Chrome-created shortcuts

Here's what an example .desktop file (this web page) created using this process has in it:

Chrome-created desktop shortcut opened in vim

Note - DO NOT rename the UUID string to something else, I tried it and the shortcut appears not to work anymore.

If you want to "uninstall" the shortcut you can just delete it, or in the open shortcut there's an option in the 3-dot menu to "Uninstall "

Reference: https://support.patientrewardshub.com/hc/en-us/articles/200086137-Creating-a-Website-Shortcut-on-your-Desktop

| improve this answer | |
0

This is a rather strange solution, but still it helped me: I also did not have the "Allow Launching" option, and I tried to recreate the Desktop folder. I copied it through the terminal, deleted the original of this folder and then renamed the copy back to Desktop (maybe instead you can just rename the Desktop folder and then return its name back). After that, I rebooted the computer and the option "Allow Launching" appeared. I have no idea why this worked, but it worked -_-

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.