2

I have trouble with my HP EliteBook laptop with AMD graphic card. I am using Xubuntu 18.04. Control of brightness is not working, I dont have option for adjustment of brightness in Settings of Power Management and when I tried to change brightness by keys then I can see bubble with bar of brightness, it is changing but brightness is still same. Please help me what I can do for working controlling of brightness.

Some details of my system below

Kernel:
5.1.0-050100-generic

Graphic card:
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev d9)
04:00.7 Non-VGA unclassified device: Advanced Micro Devices, Inc. [AMD] Device 15e6

/sys/class/backlight$ ls -la  
drwxr-xr-x  2 root root 0 říj 28 21:43 .  
drwxr-xr-x 74 root root 0 říj 28 21:43 ..  
lrwxrwxrwx  1 root root 0 říj 28 21:43 acpi_video0 -> ../../devices/pci0000:00/0000:00:08.1/0000:04:00.0/backlight/acpi_video0

Grub param  
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset iommu=soft"

I tried different setup of param in grub like

acpi_backlight=vendor  
acpi_backlight=video  
acpi_backlight=none  
acpi_osi=  

This I can see in dmesg

[ 0.771144] ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x000000005) is beyond end of object (length 0x5) (20190215/exoparg2-396)
[ 0.773527]ACPI Error: Aborting method _TZ.GETP due to previous error (AE_AML_PACKAGE_LIMIT) (20190215/psparse-531)
[ 0.774029] ACPI Error: Aborting method _TZ.CHGZ._CRT due to previous error (AE_AML_PACKAGE_LIMIT) (20190215/psparse-531)
[ 0.775197] ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x000000005) is beyond end of object (length 0x5) (20190215/exoparg2-396)
[ 0.793303] ACPI Error: Aborting method _TZ.GTTP due to previous error (AE_AML_PACKAGE_LIMIT) (20190215/psparse-531)
[ 0.806552] ACPI Error: Aborting method _TZ.CHGZ._TMP due to previous error (AE_AML_PACKAGE_LIMIT) (20190215/psparse-531)
[ 0.819896] ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x000000005) is beyond end of object (length 0x5) (20190215/exoparg2-396)
[ 0.915765] ACPI Error: Aborting method _TZ.GETP due to previous error (AE_AML_PACKAGE_LIMIT) (20190215/psparse-531)
[ 0.929800] ACPI Error: Aborting method _TZ.CHGZ._CRT due to previous error (AE_AML_PACKAGE_LIMIT) (20190215/psparse-531)
[ 0.966650] battery: ACPI: Battery Slot [BAT0] (battery present) [ 3.076060] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 3.190859] ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B08 conflicts with OpRegion 0x0000000000000B00-0x0000000000000B06 (_SB.PCI0.SMBS.SMBO) (20190215/utaddress-213)
[ 3.202553] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 5.813920] ACPI Debug: "[ReadBios] Invalid Command Type"

Another information of my GPU

Graphics:
Card: Advanced Micro Devices [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
bus-ID: 04:00.0
Display Server: x11 (X.Org 1.20.4 ) drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
Resolution: 1920x1080@77.00hz
OpenGL: renderer: llvmpipe (LLVM 9.0, 128 bits) version: 3.3 Mesa 19.2.0-devel Direct Render: Yes

  • Wasn't the default kernel for Xubuntu 18.04 LTS version 4.15 ? – K7AAY Oct 28 at 21:13
  • 1
    Yes, it was but behavior was same, it is not working in 4.15 too – drastys Oct 29 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.