2

After upgrading from 19.04 to 19.10 something seems to have gone wrong with broadcom-sta-dkms.

When I run sudo apt update and then sudo apt upgrade, it gets stuck after outputting the following (after depmod... nothing happens):

Setting up broadcom-sta-dkms (6.30.223.271-11) ...
Removing old broadcom-sta-6.30.223.271 DKMS files...

-------- Uninstall Beginning --------
Module:  broadcom-sta
Version: 6.30.223.271
Kernel:  5.3.0-19-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

wl.ko:
 - Uninstallation
   - Deleting from: /lib/modules/5.3.0-19-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

update-initramfs......

DKMS: uninstall completed.

------------------------------
Deleting module version: 6.30.223.271
completely from the DKMS tree.
------------------------------
Done.
Loading new broadcom-sta-6.30.223.271 DKMS files...
Building for 5.3.0-19-generic 5.3.0-050300-generic
Building initial module for 5.3.0-19-generic
This system doesn't support Secure Boot
Secure Boot not enabled on this system.
Done.

wl.ko:
Running module version sanity check.
modinfo: ERROR: missing module or filename.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.3.0-19-generic/updates/dkms/

depmod...
1

I manage to get the system working again. First, doing sudo dpkg --remove broadcom-sta-dkms allowed sudo apt upgrade to run properly. After that, I removed the wireless drivers from dkms and reinstalled them. During reinstallation it again got stuck after depmod.... After waiting for a while I used Ctrl+C to stop the process. I thought installation hadn't gone through properly, but somehow, after rebooting, I have working wifi again.

  • I had a similar problem with bcmwl-kernel-source would be blocking the upgrade... I removed it and proceed with the upgrade. I am guessing it got included in the kernel and no longer compiles as a module. – Mathieu J. Oct 29 '19 at 0:38
  • Actually I tried removing bcmwl-kernel-source first, but that didn't work. Removing broadcom-sta-dkms is what worked in my case. That allowed the upgrade to finish, but I still had no wifi, so had to remove and reinstall the drivers. – noravanq Oct 30 '19 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.