I have being trying to install Ubuntu to run alongside (or instead of) Windows without success.

Sure, I download the .iso file, run Rufus to install Ubuntu onto my 29 MB USB stick. Indeed Rufus does just that, however, when I try to boot from the USB everything hangs.

I did install Ubuntu onto my Mac using VBox; sure it worked, like a bag of nails, terrible. I am having no success with Windows. VBox 'fails' to start Ubuntu when I take that route and any other attempt at getting Ubuntu to run fail as well?

Any help to get Ubuntu running on my PC would be greatly greatly appreciated.

Thanks in anticipation,


  • 1
    Are you using BIOS or UEFI?
    – Daniel M.
    Oct 28, 2019 at 13:52
  • 2
    Did you verify the download of the ISO was flawless? (tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0) or the write to your install media was equally perfect (help.ubuntu.com/community/Installation/CDIntegrityCheck)? They be what I'd do first.
    – guiverc
    Oct 28, 2019 at 13:53
  • 1
    Also knowing what computer you are using will help, make/model at least.
    – crip659
    Oct 28, 2019 at 14:39
  • 1
    When booting from the USB, does the 'xubuntu installer' show up? Or does it hang immediately without showing any signs of an installer process. Also, I've had problems with Rufus before (I only used it for a specific distro), try YUMI instead: pendrivelinux.com/yumi-multiboot-usb-creator Oct 28, 2019 at 14:54
  • Hi Daniel, thanks for your reply and links. I am using a Lenovo PC, not sure what flavour. I did try VBox on my Mac, Ubuntu booted up ok but it was miserably slow and jumpy. Also, it took ages to get out of VBox and back to the Mac (so to speak)
    – Merv Gagen
    Oct 28, 2019 at 19:08

2 Answers 2


I have successfully install dual boot Windows 10 alongside by referring below:

How to dual-boot Linux and Windows


How To Install Ubuntu Along With Windows

But you mention VirtualBox. So are you trying to dual-boot or just to install the Ubuntu in the Virtual Box?


I just discovered I have UEFI. I just tried again to create a bootable USB using Universal USB Installer. Sure enough, everything seemed to go smoothly and Ubuntu ended up on the USB as expected. However, when I reboot the PC, with the USB in, and hold F12 expecting to be given the option to boot either into Windows or Linux, The entire boot sequence stalls with only 'Lenovo' on the screen. If I pull the USB and hard start the PC again it boots straight into Windows.

I shrunk part of my HDD to make space for a dedicated Linux partition. I created the partition and with Universal Installer put Ubuntu onto that dedicated HDD partition. Still, when I reboot and press F12 I don't see the Linux Ubuntu option to boot into.

I've been at this all day now and achieved nothing. Totally fed up right now.

Thanks for your help.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .