I just recently upgraded from Ubuntu 19.04 (Disco Dingo) to Ubuntu 19.10 (Eoan Ermine). My phpMyAdmin was removed while upgrading. Now I can't install it again.

I tried using:

sudo apt-get install phpmyadmin php-gettext

but it shows something like this:

Package phpmyadmin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'phpmyadmin' has no installation candidate

So I searched from phpMyAdmin, apt search phpmyadmin, but I didn't find any.

How can I install phpMyAdmin on this version?

  • Check that you have the universe repository installed.
    – DCowan
    Oct 28 '19 at 14:34
  • 2
    Its also no more in the packages repo: packages.ubuntu.com/disco/phpmyadmin - disco is last one listed there.
    – user8842
    Oct 29 '19 at 8:59

I am a member of the packaging team and we are doing our best to get back phpMyAdmin in the Debian buster repository ASAP (buster-backports), this will update Ubuntu afterwards.

You can use our PPA: https://bugs.launchpad.net/ubuntu/+source/phpmyadmin/+bug/1837775/comments/7

There is an open issue on our tracker for Ubuntu: https://github.com/phpmyadmin/phpmyadmin/issues/15515

And for Debian: https://github.com/phpmyadmin/phpmyadmin/issues/15236

Hope the PPA or installing manually using our website will help someone

  • 2
    Thanks for your help.
    – MH Sagar
    Oct 30 '19 at 18:46
  • 1
    Looking forward to having this in the main repo soon......
    – Saqib Ali
    Nov 6 '19 at 14:36
  • 2
    Correction - this won't make it into Ubuntu 19.10 because the package was already removed, and it might need some very heavy Release Team interaction to actually get included in Ubuntu again, and chances are it won't be put into 19.10 except via PPA because the archive is more or less 'frozen' there, to my knowledge.
    – Thomas Ward
    Nov 7 '19 at 17:11
  • 1
    Oh forgot it, did just now. But I get an error. It says there is no public key and so it can't verify the signature and thus it refuses to update.
    – Black
    Apr 22 '20 at 10:25
  • 1
    I had to add it like this: deb [trusted=yes] http://ppa.launchpad.net/phpmyadmin/ppa/ubuntu eoan main Now it works :) Thanks
    – Black
    Apr 22 '20 at 11:16

To add the ppa mentioned by William Desportes and install phpmyadmin do the following:

sudo add-apt-repository ppa:phpmyadmin/ppa
sudo apt-get update
sudo apt-get install phpmyadmin
  • 1
    seamless answer. I suppose ppa: states what ppa to add, and since there is no full path like in a URL but is a local URL continuation with a / it means from the trusted repositories instead of some random URL therefore this looks mostly...mostly...safe? Right? I am new to securityand only know basic password auth models. Jan 2 '20 at 11:59
  • Does not work. If I execute sudo add-apt-repository ppa:phpmyadmin/ppa then nothing happens.
    – Black
    Apr 22 '20 at 9:20

Obviously it has been removed for security reasons.

It popped up first in Debian Community: #916310 - 4.6 should not be shipped in a stable release - Debian Bug report logs

Then in Launchpad

Ubuntu Forums thread here: phpmyadmin missing from repository

It seems like some Debians joined the phpMyAdmin project to fix the problem in future releases.

  • can I install it by using disco repositories? If so how?
    – MH Sagar
    Oct 29 '19 at 11:59
  • You know you can install it directly by downloading, uploading und running install? phpmyadmin.net You can try using disco package, but it might be linked to older php packages that do not exist on eoan, it might be possible to run them with php-fpm, but I think its easier for now to use the manual install.
    – user8842
    Oct 29 '19 at 12:59

Ubuntu "focal" 20.04 has now phpMyAdmin 4.9.2


Track progress for 19.10 (if some can be done) in https://github.com/phpmyadmin/phpmyadmin/issues/15515

  • How to upgrade from Ubuntu 19.10 to 20.04 ? I tried do-release-upgrade -c but it says No new release found.
    – Black
    Apr 22 '20 at 9:40
  • 1
    No need to upgrade As I mentioned here: github.com/phpmyadmin/phpmyadmin/issues/… You can use "deb ppa.launchpad.net/phpmyadmin/ppa/ubuntu eoan main" Apr 22 '20 at 9:44
  • 1
    Ok thanks. I figured out that 20.04 is getting released tomorrow, thats prob why it was not able to find a new release.
    – Black
    Apr 22 '20 at 9:49
  • I added deb ppa.launchpad.net/phpmyadmin/ppa/ubuntu eoan main into /etc/apt/sources.list but now I get Misshaped entry 51 in list file /etc/apt/sources.list (URI parse) if I execute apt-get install phpmyadmin
    – Black
    Apr 22 '20 at 10:01
  • Edit: I had to add http://, However it does still say that it was unable to found the packet.
    – Black
    Apr 22 '20 at 10:07

You can just use heidiSQL instead of phpmyadmin.

Not the answer you're looking for? Browse other questions tagged or ask your own question.