7

I updated my ubuntu 19.04 to 19.10. After updating there are plenty of lagging occurs in few seconds every time.

Issue is the cursor and keys freezes for a few seconds, especially when trying to switch windows.

I have hybrid graphics (intel and AMD). I try to play with those settings but no luck.

Here are the details of it:

  1. This is not a performance issue, system monitor is showing that resource usage (CPU, RAM, Drive) is under control.

  2. The issue gets worse with Ethernet and WiFi

  3. The issue gets worse with dual monitors

Please suggest some steps to find the root cause of this.

  • 1
    Under grub advanced options for Ubuntu select a previous kernel version and see if that improves speed. – WinEunuuchs2Unix Oct 28 '19 at 11:49
  • @WinEunuuchs2Unix Yes. selecting the previous kernal version did the trick. So where should I go from here? – Janaka Dombawela Oct 28 '19 at 17:36
  • 1
    I posted an answer. If acceptable to you click the grey check mark next to it so others know what works for the problem. Thanks, – WinEunuuchs2Unix Oct 28 '19 at 22:58
4

As verified in comments the solution to lagging is to reboot into grub's Advanced Options for Ubuntu menu and select an older kernel.

Going forward try out each new kernel the system installs until one finally works properly. You can tell when a new kernel is being installed because update-initramfs and update-grub run with very unique output. Additionally you will see the new kernels on the grub Advanced Options for Ubuntu menu.

Make sure you do not autoremove the kernel that is working for you now. The only way you can autoremove it is to boot into a newer kernel and type:

sudo apt autoremove

So don't do that!

| improve this answer | |
  • I found that bumping down to the previous kernel (for xubuntu was 5.3.0-23 bumped down to 5.0.0-36) and trying to change video driver (nvidia 430 to 435 to X) fixed this and it's gone even after going back to 5.3 and nvidia 435 BUT the process has deleted all my display settings so my ultrawide is currently 1024x768. So I'll now go through the laborious process of fixing this. Anecdotally lnux kernel 5.4 should be released very soon (end Nov 2019) which will hopefully fix this issue. – dez93_2000 Nov 23 '19 at 19:26
  • @dez93_2000 So going to an older kernel and then reinstalling your nvidia driver fixed it for you? – Dzinic Nov 26 '19 at 17:03
  • Ah I thought it did but now I'm not sure. I've managed to repair the video driver in the newer kernel (it broke in both older then newer) so the new kernel is now working video driver but kernel stutter; old kernel is bad video but no stutter. With me being out of the house & the US holidays approaching I'm hoping there's a new kernel push which magically fixes everything for me! – dez93_2000 Nov 27 '19 at 17:48
  • Edit: 5.3.0.23 bad, 5.3.0.24 now newest still bad, 5.4 won't be included in packages until 20.04 in April. Looks like my 5.0.0.36 may have been autocleaned out as it only keeps 1 older version so I might have to put up with this til April. BOO. – dez93_2000 Dec 10 '19 at 1:07
  • 1
    @dez93_2000 It is better to post a new question with all your system details and brief history of how the problem developed. – WinEunuuchs2Unix Mar 22 at 12:29
1

The problem is apparently caused by the swapping and disk writes in general. I found my solution by manually downgrading to kernel 5.2.21 from https://kernel.ubuntu.com/~kernel-ppa/mainline/

I'm now running it second day without problems. Micro freezes are gone and system is generally more responsive.

| improve this answer | |
  • how do I downgrade my version? – Chiptus Apr 24 at 22:10
  • I simply downloaded kernel builds relevant for me (amd64, generic) frorm here: kernel.ubuntu.com/~kernel-ppa/mainline/v5.2.21 A only need headers, image and module for amd64, generic. Then I installed these deb files one by one as follows sudo dpkg -f linux-image-unsigned-5.2.21-050221-generic_5.2.21-050221.201910111731_amd64.deb etc. etc. Finally I restart system and select this kernel to be loaded in Grub menu. Of course you need to do this on every restart. – user1046748 May 3 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.