6

I had a couple of extensions installed in ubuntu 19.04. After upgrading to 19.10 they are all disabled (I look them up in Tweaks app). Beforehand, I had installed them using a firefox extension, but now when I try to install the same items it is not possible, probably it finds the previous installations and refuses to do a new install. Thanks

3
  • 2
    Are these extensions 19.10 compatible? – George Udosen Oct 28 '19 at 5:14
  • GNOME extensions do not always work in different versions of GNOME; and thus get disabled. You need to check for each extension that it works in GNOME 3.34 (19.04 used 3.32) or if you need to get a newer version of the extension (if available, or switch to a different extension that achieves your goal). Ubuntu only does this for the supported extensions found in the installation; for any you've added you need to do this yourself – guiverc Oct 28 '19 at 5:24
  • You may need to experiment with different versions of gnome. For example "Put Windows" required version 26. See this answer to a question askubuntu.com/a/1181164/307670 Don't forget to restart gnome after any changes Alt+F2+r – 24601 Oct 28 '19 at 6:30
24

I found in Tweaks in the top right, there's a switch that was turned off. Turning this on activated all my extensions.

enter image description here

3
  • 1
    Not sure if your answer helped to topic starter, but it sure did help me :-) – localhost Jan 20 '20 at 7:34
  • Thank you, this helped for me too! But it's still a mystery why this switch was suddenly turned off from one boot to the next... – Ghostkeeper Mar 18 '20 at 9:52
  • Thank you! It look me a long time to find this - it really should be shown on the Gnome Extensions webpage. An equivalent command is gsettings set org.gnome.shell disable-user-extensions false – ZimbiX Feb 19 at 20:21
4

Download the extensions you want from https://extensions.gnome.org/ Select the latest version of that extension.

Most of the time they will be in zip format so extract the file from the zip folder. Open the extracted folder and locate the metadata.json file. In that file, replace the shell-version with the one you currently have and save. Also copy the uuid and use it to rename the extracted folder.

After you've done this, copy and paste that extracted folder(with the uuid as it's new name) in the extensions folder located in .local/share/gnome-shell

Once you've done this, restart your gnome shell and your extensions should be working. Don't forget to enable extensions in the Tweaks app.

2
  • 3
    After a Gnome crash, all my extensions were disabled. Re-enabling them on extensions.gnome.org didn't help. This answer helped me solve the problem: re-enable the Extensions support on the Tweaks app. – Fábio Batista Nov 20 '19 at 19:12
  • 3
    Oh man, I have been struggling with this since making the upgrade to 19.10 and it never even occurred to me to look in the Tweaks app. Sure enough, extensions were disabled there. Flipped the switch to turn them on again and all my extensions came right back. Many thanks @FábioBatista! – jalefkowit Nov 20 '19 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.