4

Today I've upgraded Kubuntu from 19.04 to 19.10 on my laptop and faced following issue - tapping doesn't work anymore. One-finger touchpad tap doesn't work as left click and two-finger touchpad tap doesn't work as right click too.

I opened system settings and found that tapping section is totally disabled, see screenshot.

Touchpad settings with tapping options disabled

How this issue could be fixed?

4 Answers 4

5

Googled a bit and found only one solution - edit Xorg config (you'll need sudo to do it). Maybe someone will suggest better one.

At first open /usr/share/X11/xorg.conf.d/40-libinput.conf and find touchpad section:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Then add two tapping options to the end of section so it will look as follows:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "True"
        Option "TapButton2" "2"
EndSection

Note: TapButton2 option as I found at https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Frequently_used_options configures "which mouse-button is reported on a non-corner, two finger tap".

Logout&login and touchpad should start work correctly.

As a bonus now GUI tapping options are enabled, see screenshot.

enter image description here

1
  • In Kubuntu 20.04 GUI option works well without any configs/scripts tuning.
    – QtRoS
    Feb 22, 2021 at 19:21
2

It worked like a charm! Just one comment: you don't need to logout and login. After saving changes to 40-libinput.conf, open touchpad dialog and tapping options will be enabled.

1
  • Thanks for comment! One question - maybe tapping options will be enabled but will tapping work? As far as I understand to apply Xorg settings Xorg server should be restarted, to make it logout&login is needed for example. Oct 28, 2019 at 1:18
2

Thank you for the info, it was helpful. I just now got around to upgrade and did hit this problem too.

A couple of notes:

  1. I will suggest to copy the conf file to /etc/X11/xorg.conf.d/ and then edit it. I did that and just deleted all other sections in the file. The reason is that the original file will potentially be overwritten by updated packages. You avoid this by changing the location and /etc/X11/xorg.conf.d is where you are expected to put you own xorg settings.
  2. The TapButton2 entry is not needed. It works without it and you can choose between right or middle click in the kde gui interface.
  3. You do not need to log out for it to take effect. I just added the file and reopened settings. The options where now available and as soon as I did hit apply everything worked right away.
1
  • Glad that it helped you and thanks for notes! Dec 16, 2019 at 3:57
0

Create a new file at /etc/X11/xorg.conf.d/40-libinput.conf and paste the following lines

# Match on all types of devices but joysticks
#
# If you want to configure your devices, do not copy this file.
# Instead, use a config snippet that contains something like this:
#
# Section "InputClass"
#   Identifier "something or other"
#   MatchDriver "libinput"
#
#   MatchIsTouchpad "on"
#   ... other Match directives ...
#   Option "someoption" "value"
# EndSection
#
# This applies the option any libinput device also matched by the other
# directives. See the xorg.conf(5) man page for more info on
# matching devices.

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "True"
EndSection

Restart your settings app and you are good to go

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .