2

My system is Linux/Lubuntu 18.04.3.LTS, 64 bit. I´ve been using recoll for quite a while now. I´ve updated to version 1.26.1 just now and noticed that clicking on "Show query history" doesn´t yield any results". What could be the matter here? It used to work just fine.

The ~/.recoll/saved_queries folder is empty. So no query history is stored in the first place.

Tnx and cheers

UPDATE:

With the help of Jean-François Dockes, the Recoll developer, I could solve the problem: You need to edit ~/.config/Recoll.org/recoll.conf and add/change the following line with a text editor:

prefs\historysize=-1

In my case the value was set to "0", therefore no query history. With the value of "-1" it works just fine.

screenshot settings for Recoll 1.23.7 + Xapian 1.4.5

enter image description here

0

Note that in addition to the prefs\historysize setting, if you have recoll version 1.26.0 or later this can also be changed with the GUI by going to "Preferences" -> "GUI configuration" and setting "Maximum size of search history" to -1.

Recoll - User Preferences

This feature was added October 4, 2019.

| improve this answer | |
  • Hi Nathaniel. Thanks for your suggestion. Alas my GUI doesn´t have the respective option. See my original post: "screenshot settings for Recoll 1.23.7 + Xapian 1.4.5". So editing ~/.config/Recoll.org/recoll.conf seems to be my only solution. – Rosika May 7 at 13:16
  • @Rosika Thanks for the reminder; I forgot that I'm using a PPA with a more recent version. I've added the version this feature was added to avoid confusion. – Nathaniel M. Beaver Jun 19 at 16:53
  • Thanks for the information. It´s all clear now. – Rosika Jun 21 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.