0

I have an issue with mounting my NTFS data partition (separate drive). This is the drive (fdisk -l):

Disk /dev/sdb: 232,9 GiB, 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00095dd3

Device     Boot Start       End   Sectors   Size Id Type
/dev/sdb1        2048 488396799 488394752 232,9G  7 HPFS/NTFS/exFAT

I mount it through a fstab entry with my user and my user group and full permissions:

/dev/sdb1    /home/asche/dtn     ntfs-3g  defaults,nls=utf8,umask=000,auto,uid=1000,gid=1000           0  0

It shows up normally in Nautilus and in terminal (ls -ll ~):

drwxrwxrwx  1 asche asche    4096 Okt 22 21:42  dtn

Also all the data is there under ~/dtn. I just don't have permission to delete, cut, rename etc (so, I guess read-only is granted).

Any ideas on how to change my fstab file? I have tried quite a bunch by now...

I am running Ubuntu 18.04 LTS and Win10 in dual boot.

  • 1
    Please edit your question to say which version of Ubuntu you are using. – User24601 Oct 26 '19 at 13:45
  • Done! 18.04LTS :) – Klaster Oct 26 '19 at 14:06
  • 1
    Okay, your links got me on the right track! It was due to Win10 not shutting down decently in dual boot... Need to shutdown windows with pressing SHIFT + Shut down Thanks! – Klaster Oct 26 '19 at 14:51
  • 1
    Excellent news. Post that as an answer to your question and then wait a few days to mark it as accepted. – User24601 Oct 26 '19 at 14:53
  • 1
1

The solution lay not in any Ubuntu settings, but in the dual boot with Windows 10. Windows 10 has a fast boot option that hibernates the system instead of shutting it down decently. This results in ubuntu being able to mount the NTFS disk in read-only.

To shut down Windows 10 effectively, press SHIFT + Shut down button or follow instructions in the internet (e.g. this tutorial)

See other posts on this plattform as well, e.g. Why does my NTFS partition mount as read only?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.