4

I recently upgraded to Ubuntu 19.10, but I'm not able to open Settings.

killall gnome-control-center

gives

gnome-control-center: no process found

And also my laptop is hanging many times, I had to press the power button every time to restart.

gnome-control-center --verbose

gives

Segmentation fault (core dumped)

but gnome-control-center --version gives gnome-control-center 3.34.1

  • 1
    Upgrade pain. In many cases, it is much better not to upgrade an existing install, but to freshly reinstall a new Ubuntu version. – vanadium Oct 26 '19 at 9:35
  • Is there a way other than reinstalling? – learner Oct 26 '19 at 14:41
  • 1
    What's the output of this command: echo $XDG_CURRENT_DESKTOP – Gunnar Hjalmarsson Oct 28 '19 at 3:15
  • @Gunnar it say's ubuntu:GNOME – learner Oct 28 '19 at 8:08
  • I'm not convinced this is upgrade related. Having the same issue on my freshly installed 19.10 machine. – Ceisc Dec 10 '19 at 10:30
9

It also happened to me when I tried to open Devices section.

Someone pointed out that you can reset the last panel using a terminal:

gsettings set org.gnome.ControlCenter last-panel ''

It does not solve the Devices section issue.

  • 1
    I have seen that problem on non-GNOME desktops - it's this bug. – Gunnar Hjalmarsson Oct 28 '19 at 3:17
  • 1
    Thank you very much it worked – learner Oct 28 '19 at 8:39
  • @GunnarHjalmarsson apparently there is a fix released... wondering when we may get it – Alexandre Oct 28 '19 at 20:10
  • 1
    @Alexandre: That "fix released" is about non-GNOME desktops (i.e. not the case for the OP of this question), and the "fix" consists of a proper error message instead of segfaulting. Not sure about the status of the issue on GNOME desktops. – Gunnar Hjalmarsson Oct 28 '19 at 22:28
  • 1
    @learner: Ah, that may explain it. AFAIK g-c-c requires bot gnome-shell and mutter to work as expected, but hidmi-damon might be a way to work around that requirement. – Gunnar Hjalmarsson Oct 29 '19 at 4:54
0

try to take a screenshot of your screen, and look at the picture. If the setting is on the right side of the screen that means you have accidentally opened a join screen. You can search for turning a join screen from the terminal. Hope this would help.

New contributor
Ziya Alim is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    May you edit your answer and explain a bit more about what a "join screen" is? Also, what you mean by "turning a join screen from terminal"? A screen shot may be helpful. – Gordster Mar 25 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.