Im using ubuntu 9.10

I have the following mobo in the computer: http://www.netonnet.se/art/dator/datorkomponenter/moderkort/intel-775/ASUS-P5KPL-AMSE/127329.4026/ (ASUS P5KPL-AM SE)

The mobo uses a Intel GMA 3100 integrated graphics card.

Now on the problem: Running glxgears om the computer does not work. Googled on the problem and found out that Nvidia and ATI/Radeon drivers interference with the intel drivers.

So I uninstalled all Nvidida and ATI/Radeon drivers. Then I runned Xorg :1 -configure , and then cp /root/xorg.conf.new /etc/X11/xorg.conf

But then after a reboot, im notice the login screen graphics are much better. But im unable to login, I only get kicked back to login screen all the time when I enter correct password. (Theres no problem with the password, the system "senses" if the correct or incorrect password is specificed).

I had to go in via SSH, and add "skljsfjsljfssf" at the end of xorg.conf to make it "munged". After a reboot, the computer went into low graphics mode and Im able to login normally.

Whats the problem with logging in after having configured Xorg?

My /etc/X11/xorg.conf:

Section "ServerLayout"
  Identifier "X.org Configured"
  Screen 0 "Screen0" 0 0
  InputDevice "Mouse0" "CorePointer"
  InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
  ModulePath "/usr/lib/xorg/modules"
  FontPath "/usr/share/fonts/X11/misc"
  FontPath "/usr/share/fonts/X11/cyrillic"
  FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/Type1"
  FontPath "/usr/share/fonts/X11/100dpi"
  FontPath "/usr/share/fonts/X11/75dpi"
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath "built-ins"
Section "Module"
  Load "record"
  Load "dri"
  Load "dbe"
  Load "dri2"
  Load "glx"
  Load "extmod"

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "kbd"

Section "InputDevice"
  Identifier "Mouse0"
  Driver "mouse"
  Option "Protocol" "auto"
  Option "Device" "/dev/input/mice"
  Option "ZAxisMapping" "4 5 6 7"

Section "Monitor"
  Identifier "Monitor0"
  VendorName "Monitor Vendor"
  ModelName "Monitor Model"

Section "Device"
  #Available Driver options are:-
  #Values: <i>: integer, <f>: float, <bool>: "True"/"False",
  #<string>: "String", <freq>: "<f> Hz/kHz/MHz"
  #[arg]: arg optional
  #Option "NoAccel" # [<bool>]
  #Option "SWcursor" # [<bool>]
  #Option "ColorKey" # <i>
  #Option "CacheLines" # <i>
  #Option "Dac6Bit" # [<bool>]
  #Option "DRI" # [<bool>]
  #Option "NoDDC" # [<bool>]
  #Option "ShowCache" # [<bool>]
  #Option "XvMCSurfaces" # <i>
  #Option "PageFlip" # [<bool>]
  Identifier "Card0"
  Driver "intel"
  VendorName "Intel Corporation"
  BoardName "82G33/G31 Express Integrated Graphics Controller"
  BusID "PCI:0:2:0"

Section "Screen"
  Identifier "Screen0"
  Device "Card0"
  Monitor "Monitor0"
  SubSection "Display"
    Viewport 0 0
    Depth 1
  SubSection "Display"
    Viewport 0 0
    Depth 4
  SubSection "Display"
    Viewport 0 0
    Depth 8
  SubSection "Display"
    Viewport 0 0
    Depth 15
  SubSection "Display"
    Viewport 0 0
    Depth 16
  SubSection "Display"
    Viewport 0 0
    Depth 24
  • Fly.Floh comments: Try running X from the command line: * go to a terminal with ctrl + alt + f1 (or any f key betwenn 1 and 6), log in there * type sudo stop gdm (or sudo stop kdm if you're on kubuntu) to stop the running x server * type startx to start the x server while logged in what happens now? is there any output on the terminal? you might want to include that in your post. – txwikinger Nov 7 '10 at 0:59

I would suggest you remove /etc/X11/xorg.conf and let Xorg detect everything itself while starting up, as that's the recommended way (especially if you are using open source drivers like the 'intel' ones).

The Xorg -configure option is probably still there for non-linux operating systems.

  • Thanks for the solutions. Tested them all, found out that some driver was missing. Reinstalling Ubuntu solved the problem but made glxgears nonfunctional again. Removing NVIDIA drivers but not ATI drivers solved all problems and made glxgears function. (It was when removing ATI drivers that made it nonfunctional). Login and desktop is functional with Xorg -configure now. – sebastian nielsen Nov 7 '10 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.