3

I just got a Dell XPS 13 7390 (2-in-1). It was originally shipped with Windows 10, then I installed Ubuntu 19.10, dual boot with the original Windows 10.

The problem I have now is that after I suspend Ubuntu by closing the lid, I cannot wake the laptop back up. When I open the lid, the screen just shows the dell logo and wouldn't go anywhere even after waiting for 30 minutes.

I would have to force shut down the laptop and turn it back on again.

2

I have the same problem. I can't see anything even if I close the lid. So I want to know a more fundamental solution than what I have found.

This is not a good solution, but I edited /etc/systemd/logind.config and changed the variable:

# HandleLidSwitch = default

To:

HandleLidSwitch = ignore

(with no sharp)

If I am not using this laptop, I can press Ctrl+L. But this way, the computer will run out of almost battery on next day.

2

I found a solution, but it is not ideal. The problem appears to be with active power state management and NVMe and the PCI bus according to Google. Until that bug gets fixed, you can get sleep/wake to work by editing your /etc/default/grub file to include in the default kernel arguments:

GRUB_CMDLINE_LINUX_DEFAULT=" ...stuff...  pcie_aspm=off"

This turns off active state power management of some aspect of the PCI interface. This solved the problem for me completely. The downside is that there is no longer active power management of the PCI interface and so the power consumption of the laptop is unnecessarily high. I don't know how much of a drain this is though.

I have installed on my machine 'tlp' power management, and then installed the ACPI tools to control the CPU frequencies that way (you have to set intel_pstate=passive in the kernel parameters to use ACPI to control the CPU frequencies). Using 'powertop' shows my idle usage on battery to be about 5 watts. Some people have got their power consumption down to 4 or 5 watts even when they are doing something on the machine, so it seems there is more work to do to save battery life as long as we turn off aspm.

Update: 02 Dec 2019. You can still use intel_pstate driver to control frequencies. In this case don't set intel_pstate to passive, just don't set it. To set cpu frequencies, see the post here: can't control cpu frequencies in 19.10 on 7390 xps 13 2-in-1

With the cpu frequency set to 400MHz on battery, I can get my power consumption down to about 3.5 Watts at idle.

1

Googling reveals that several people solved this issue on other Dell XPS models by adding mem_sleep_default=s2idle to the GRUB command line at boot or updating the GRUB's config file.

I tried this, then put the computer to sleep from the menu instead of closing the lid. To my surprise the computer woke up when I hit Space. It had never done that before. Strangely it only worked once. I'm guessing this is not the issue though.

1

Sebatian Stark's solution is the only one that worked for me on my XPS 2-in-1 7390. Reproduced here for convenience:

Add the following to the file /etc/systemd/sleep.conf:

[Sleep]
SuspendState=freeze
0

This worked for my Dell 7390: Add kernel boot param to /etc/default/grub (and then: sudo update-grub + reboot):

GRUB_CMDLINE_LINUX_DEFAULT=" ...stuff...  intel_idle.max_cstate=1 i915.enable_dc=0"

See: Dell Latitude 7390 - Ubuntu 20.04 - Sometimes hangs and reboot after pressing "Suspend"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.